IDVD 4.01 is not working under MAcOSX10.5.8

October 2017




Issue


I've recently upgraded to OSX.5 and since then iDVD 4.0.1 is not working.
  • Error message:
    • "Can not open this version of the application with this version of Mac OSX"
  • So I downloaded the necessary updates: iDVD401Update.dmg and then iDVD501Update.dmg iDVD_604.dmg.
  • When iDVD401Update launches, I get the message:
    • "iDVD 4.0.1 Update can not be installed on this machine.iDVD 4.0 is not found in / Applications."
  • Upon using iDVD501Update,I'm getting a similar error message.
  • Is there any solution to correctly install IDVD

Solution


I suggest you read the recommendations for Apple Leopard.
  • Under Leopard, there's no way to switch from iDVD4 to iDVD 6.
  • You can't update your iDVD4 to version 5 or 6 via free upgrades (5.0.1 or 6.0.1 or 6.0.4): they are valid only if you previously purchased and installed iDVD5 or iDVD6.


Thanks to Ritchi for this tip!
Published by aakai1056. Latest update on April 12, 2011 at 10:22 AM by aakai1056.
This document, titled "IDVD 4.01 is not working under MAcOSX10.5.8," is available under the Creative Commons license. Any copy, reuse, or modification of the content should be sufficiently credited to CCM (ccm.net).