VirtualDub - Unable to open Avi/Xvid file

October 2016


Upon opening a movie with VirtualDub, the following error message is displayed:
"VirtualDub requires a video for windows(VFW) compatible codec to decompress video. DirectShow codec, such as those used by Windows Media Player, are not suitable." .
What can be done to solve this issue?


You need to install ffdshow:
  • Close VirtualDub.
  • Go to
  • Download the latest stable version available.
  • You will be prompted for intergration with VirtualDub. Check the appropriate box and proceed!
  • Reopen VirtualDub and open the Xvid video.

Related :

This document entitled « VirtualDub - Unable to open Avi/Xvid file » from CCM ( is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.