OCS error - Invalid command 'PerlSetEnv'

June 2017




Issue


I have just finished installing OCS Inventory Agent for Linux Server on Redhat Enterprise 4 but now my httpd service wont start, it is giving me the error below:

Starting httpd: Syntax error on line 16 of /etc/httpd/conf.d/ocsinventory.conf:
Invalid command 'PerlSetEnv', perhaps mis-spelled or defined by a module not included in the server configuration.

Solution


Just add 'perl' in:
/etc/sysconfig/apache2
Under the APACHE_MODULES section.

Note


Thanks to mrslash for this tip on the forum.

Related


Published by aakai1056. Latest update on December 30, 2009 at 08:27 AM by aakai1056.
This document, titled "OCS error - Invalid command 'PerlSetEnv'," is available under the Creative Commons license. Any copy, reuse, or modification of the content should be sufficiently credited to CCM (ccm.net).