PC No display/beeps

barelyhere 2 Posts Sunday November 26, 2017Registration date November 29, 2017 Last seen - Nov 26, 2017 at 10:00 PM - Latest reply: barelyhere 2 Posts Sunday November 26, 2017Registration date November 29, 2017 Last seen
- Nov 29, 2017 at 06:36 PM
Hello,
I recently built my first pc and to my knowledge everything is plugged in correctly. Everything powers up, fans spin, mobo power button lights up, gfx card fans whirl. However, I get NO DISPLAY or BEEPS.

These are my specs:
- Intel Core i5-7600K Kaby Lake Quad-Core 3.8 GHz LGA 1151 91W BX80677I57600K Desktop Processor
- GIGABYTE G1 Gaming GA-Z170X-Gaming 7 (rev. 1.0) LGA 1151 Intel Z170 HDMI SATA 6Gb/s USB 3.1 USB 3.0
- EVGA GeForce GTX 1050 Ti SSC GAMING ACX 3.0, 04G-P4-6255-KR, 4GB GDDR5, DX12 OSD Support (PXOC)
- WD Blue 1TB Desktop Hard Disk Drive - 7200 RPM SATA 6Gb/s 64MB Cache 3.5 Inch - WD10EZEX - OEM
- CORSAIR Vengeance LPX 8GB (2 x 4GB) 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) Desktop Memory Model CMK8GX4M2B3000C15
- CORSAIR VS Series VS600 (CP-9020119-NA) 600W ATX12V / EPS12V 80 PLUS Certified Active PFC Power Supply

What I've done:
- Removed ram and powered on pc - no display/beeps, pc keeps turning on and off every 3 seconds

-Plugged a different monitor into the gfx card opening - no display/beeps

-Plugged first monitor to the gfx opening on mobo instead of gfx card - no display/beeps

I don't know what else to do anymore. Thank you for reading!



See more 

2 replies

Reply to this topic
xpcman 18205 Posts Wednesday October 8, 2008Registration dateModeratorStatus December 12, 2017 Last seen - Nov 27, 2017 at 07:46 PM
0
Helpful
1
When I see this type problem. I suspect a possible CPU/BIOS problem. This is what you get when the BIOS quits the boot and restarts. Are you sure that CPU is supported by the BIOS version you have? Are you sure the CPU is correctly inserted into the socket?
barelyhere 2 Posts Sunday November 26, 2017Registration date November 29, 2017 Last seen - Nov 29, 2017 at 06:36 PM
Thank you for responding. Yes I am sure that the CPU is compatible with the BIOS and that it is inserted correctly.
Respond to xpcman