Ask a question Report

External drive very slow copying data to D: [Solved/Closed]

wakantanka - Latest answer on Jul 17, 2013 07:02PM
Hello,
My external drive is extremely slow copying music and data to my D: drive, the format of both the drives is ntfs, and my anti virus is not scanning, when i drag and drop from one to the other the copying is extremely slow.
Please not too technical thanks
Read more 
Answer
+48
moins plus
Howto: Fix Slow USB 2.0 file transfer on Windows XP
August 11th 2010
USB storage devices can be optimized for either quick removal or performance. If optimized for quick removal, data transfer can potentially be reduced to a crawl.

To optimize your USB drive for performance:
1.Right click on the USB drive and select properties
2.Select the Hardware tab
3.Under All Disk Drives, highlight your USB drive and select Properties
4.Select the Policies tab and select Optimize for performance.
5.Press OK twice, and your transfer speeds should increase dramatically
Note that when your drive is optimized for performance you'll need to use the Safely Remove Hardware icon in the taskbar to eject the drive - otherwise you'll risk corrupting your data by just removing the drive from the port.

Tapas Karmakar- Apr 14, 2013 02:44AM
Its totally agreed ....
Yam- May 7, 2013 02:15AM
Nice .. thx Freshtex!
but u need to click on Change settings for goo to Policies tab :P
avi- Jun 1, 2013 04:20AM
I have tried Also But when i click to optimize performance and press ok the windows said that it cannot be changed probacilly because windows does not allow to change the configuration
Dushyant- Jun 16, 2013 07:23AM
i tried it it really does remarkably to solve my issue ..thx .
sgagliozze- Jul 17, 2013 07:02PM
what if i turn off the computer? will it cause my external drives to corrupt some data?
Answer
+27
moins plus
tried loads of things even microsoft recommended settings. found this great......its bloody works, thanks to the super brain who worked it out
Go to
1. Control panel
2. System and Maintenance
3. Administrative tools
4. Run services shortcut
Once the services program loads find the services called Background intelligent transfer service and stop it
also right click on the same service and click properties then change the start value to manual or disabled this should also fix the network problem and USB copy and paste problem
.
Amazing problem solved

justme- Jan 1, 2013 02:52AM
Your solution works! Do i have to keep doing it for all computers i use my drive on?
chiccosinalo- Jan 1, 2013 10:35AM
thanks so much it worked for me. :)
Mostros10- Jan 5, 2013 11:51AM
Big problem, easy solution.....Thank you
Answer
+10
moins plus
Go to device manager & try optimizing the drive for performance.

Goto: Device manager/Disk Drives
Find the disk and right click for properties option.
Click 'Policies' tab'
Check "Better Performance"

That should solve the problem.

123- Mar 1, 2012 01:16PM
thanks bro....................
swag- Oct 31, 2012 10:45PM
thank uuu
devilonway- Dec 21, 2012 01:55AM
Thanks
Answer
+6
moins plus
This may or may not address your problem. I just upgraded from XP to a new PC running Vista. MY external USB 2.0 hard drive used to work quickly
(30 MB/sec), but now was running extremely slowly (1.5 MB/s, if I'm lucky).

Vista would tell me that my device could perform faster if I connected it to a USB 2.0 port. Well guess what? All my computer has are USB 2.0 ports. Other ports were no help.

I tried all sorts of fixes, nothing was working. The hard drive would still work fast on my old PC.

One forum suggested that some USB cables don't fully support USB 2.0.

So I tried a different USB cable, and it works perfectly. 25.6 MB/s! Put the old cable on, and it was slow again, with the same error message. Put the new cable on, and it worked fast again.

So consider trying a new cable!

Frank- Apr 4, 2013 06:21PM
The USB cable did the trick for me as well. It worked perfectly fine after many months of agony.
Answer
+5
moins plus
I also had problems with copying speed from an external USB drive to my internal one. But the problem only appeard for my movie folder on that disk, which seemed a bit odd to me and found a bit weird soloution to it:
I checked the information for the movie folder (apple+i) and compared them to the ones of a 'no problem' folder. For some reason the 'sharing & permission' section of my movie folder had two entries for me on saying 'read & write' and the other saying 'custom' above it.
I changed 'custom' to 'read & write' and everything went back to normal.

I now have reading and writing speed of 20 MB/sec. Before had 500kb/sec.
Don't now if this works for you, but it might be worth checking.

Answer
+3
moins plus
You should try using the external HDD on another pc and see if it does the same thing! May be it's because of some viruses!

Answer
+1
moins plus
I Dont Know If You Solved This Problem, But The Way To Fix It Is Change The Cluster Size To 512 Bytes, The Problem Is The Hard Drive Is Reaching Its Lifetime.

GW- Jan 15, 2013 01:32PM
I had a similar problem. SMART was OK. Eventually, measured the read and write speeds. Write was 20x slower than read! Checking with Seagate disk tools showed that the drive was about to die.
It had also caused my system to slow in an unpredictable way. After boot it was fine but at sometime over the next hour it would slow. It turned out that I'd moved the temp file to this drive as it was supposed to be fast.
Hope this helps someone.
This document entitled « external drive very slow copying data to D: » from CCM (ccm.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.