WD Ultra Passport not automaticall detected

Shankzi - Feb 3, 2018 at 03:42 PM - Latest reply: Ambucias 49709 Posts Monday February 1, 2010Registration dateModeratorStatus February 23, 2018 Last seen
- Feb 3, 2018 at 05:49 PM
Hello,

i am able to see it under the devmgmt.msc but every time I plug I have to manually assign a letter to the drive. only then I am able to see this drive
however I have tried with multiple harddrive and usb storage drive to confirm not an issue with the laptop and the other storage device works fine
Help me plz

Regards
Shankzi


See more 

1 reply

Reply to this topic
Ambucias 49709 Posts Monday February 1, 2010Registration dateModeratorStatus February 23, 2018 Last seen - Feb 3, 2018 at 05:49 PM
0
Helpful
Try this 1

1) First make sure that your hard drive is detected in the BIOS.

Check the SATA settings in the BIOS if you are using a SATA Hard Drive.

2) If the problem still exists then check all your connection connecting from the

motherboard to your hard drive. Try different data cable or power cable.

3) If its a PATA hard drive then make your CD\DVD- drive as master and the hard

drive as slave. Change the jumper settings. You can find the instruction on the

CD\DVD drive and the hard drive regarding how to set your drives as

master\slave.

Good luck
Respond to Ambucias