Ask a question Report

Total installed ram not usable. [Solved/Closed]

vin - Latest answer on May 26, 2013 06:24PM
I am vinay.
I have recently bought a dell studio 1555 with 4gb ram.
But the total usable ram is only 2.96 gb and the ramaining is reserved.
I want to use the whole 4gb ram.
I have windows 7 and it shows that the total installed ram is 4gb but usable is only 2.96 gb.
Please tell me how to use whole the ram?
Read more 

moins plus
I figured it out. After tinkering with it for a few hours, it turns out that the "Memory Reamp" needs to be enabled. On some Asus mobo's and a few other brands, when Win 7 is installed it recognizes that this problem. The problem was there all along and people just didn't know it until Win 7 was installed and pointed it out as a precursor to a BIOS problem that had been there the whole time.
1 Enter BIOS
2 Advanced
3 Chipset Settings
4 Enable Memory Reamp Feature
5 Exit and Save
6 You're Done!

moins plus
hi there,

open run>

type msconfig>

go to boot tab>advance options>

select maximum memory

apply and restart


ys- Dec 30, 2009 04:53AM
hihi dancedhall,i try ur method ad..but stil cannot work..stil 2.96 gb ram usable... =(
clayton- Sep 14, 2010 10:20AM
thanks alot for the advise it worked for me
Maximusnights- May 26, 2013 06:24PM
Hello here is something a lot of you are forgetting to mention. If you have a graphics card that id not a dedicated Graphics card then it probably uses up memory from your computer. I have an HP Pavilion G6 and it has a Radeon HD 6470M graphics card. It is a 1.5 GB graphics card and it is not Dedicated because of this the 6GB of ram I have installed I am only able to use 4.5GB of ram because the graphics card uses the other 1.5BGs. A dedicated Graphics card has it's own ram. If you have a dedicated Graphics Card and you have 6GB of ram then you will be able to use all 6BGs.
moins plus
Hey man, the problem must be that you are using a 32bits or x86 (which is another way to say it) version of windows 7, for you to fully use the installed of your comp, you need the 64bits version, however there are some little issues like imcompatibility with some softwares that go from not being able to use the program to performance issues, however if you use your comp for mmmm let's say normal stuff like office, browsing, music and movies you shoudln't be having that much of a problem.

moins plus
You have a 32 bit system. The the memory you see not available to you is for other computer resources; motherboard, video card - so you are OK!!

Vijay Virk

moins plus
yeah..its most likely that you've installed a 32 bit version of ubuntu on a 64 bit machine.

This document entitled « Total installed ram not usable. » from CCM ( is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.