Report

Connected to wifi, but can't browse [Solved/Closed]

Ask a question Oni - Last answered on Aug 9, 2017 at 03:19 PM by mgk21
Hello,
I have an acer aspire one notebook bought in Norway, Oslo. It operates on Linux software. My problem is that it connects to the wireless at my university and picks up signal powerfully, its just that when I'm connected I cannot browse the internet. My browser is firefox and I am clueless on what could be the problem. Strangely it connects and browses when I connect to lan in the library. Hope that you can help me. Thank you
See more 
Helpful
+134
plus moins
I have an Aspire One ZG5 running XP, at my weekend house I have the problem that many have described, I lose the wireless connection after a few minutes. Interestingly, I don't have this issue in my primary home so apparently there are compatability issues that contribute to the issue. In my case the dropping of the internet connection definitely seemed to be related to the netbook hibernating.
The following very simple solution worked for me. I turned the network adapter power save mode to off and the problem stopped, here are the steps:
- click "Start"
- click "Control Panel"
- click "Classic View"
- doubleclick "System"
- select "Hardware" tab
- click "Device Manager" button
- click "+" to left of "network adapters"
- doubleclick "Atheros AR5007EG ...."
- click "Advanced" tab
- select "Power Save Mode"
- select "off"
- select "OK"
MrFyde- Feb 24, 2013 at 05:09 PM
Nope. Sure didn't solve my issue. My system says I'm connected to the Internet but still unable to see a web page.
andrew- Mar 29, 2013 at 06:37 PM
i did that Brian but my internet still will not work
warier- Apr 3, 2017 at 06:16 AM
Thank you soo much i fellowed your steps and my laptop is back to normal
Reply
Wendeeeee- May 11, 2017 at 01:31 PM
Totally worked for me and I was ready to chuck this thing. Thanks!
Reply
mgk21 1Posts Wednesday August 9, 2017Registration date August 9, 2017 Last seen - Aug 9, 2017 at 03:19 PM
Not only is my internet/wi-fi now working, but my computer is now running super fast, like a core i5 should. Wonderful. Thank you. I like Acer machines, but that is a stupid setting.
Reply
Helpful
+74
plus moins
I tried all the recommendations given here but not one worked ;(. Finally I tried uninstalling the network adapter and BEHOLD.. It worked! To do this you have to:

1) Open Control Panel.
2) Open "System".
3) Open "Hardware".
4) Open "Device Manager"
5) Open "+ Networks Adapters".
6) Right Click on "Atheros AR5007EG Wireless Network Adapter".
7) Click "uninstall".
8) Reboot your system, and the computer will reinstall the device as a new hardware found.

Hope this will help. It took me a while to figure it out.

Good luck.
meee- Mar 21, 2010 at 09:12 AM
eveluta thank you this worked
Is- Mar 22, 2010 at 05:12 AM
Thank you so much! I had this problem with my Asus Eee pc, so I followed your steps (but I uninstalled '802.11n Wireless LAN Card' on step 6) and then rebooted my system... it worked! Finally...
annoyedwithwireless- Mar 25, 2010 at 06:16 PM
how do I open the control panel, and will this work on my asus Eee pc 701
meeee- Apr 5, 2010 at 07:41 AM
OMG OMG OMG I love you I worship you I can't beleive that it finally worked u are such a genius I love youuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuu u are a goddess
Poornima- Feb 24, 2013 at 04:19 PM
Worked for me :)
Helpful
+35
plus moins
access TCP/IP property.
Select "Obtain an IP Address Automatically".
Press OK
Try to browse
Jor- Jul 11, 2009 at 06:40 AM
Hey there, thanks so much for that simple tip. It turned out my dad's EEE PC had manual TCP/IP settings put in, and when I set it to automatic, I was able to browse the internet again. I also think setting the wireless card's power save feature to "off" helped, but the TCP/IP thing was he last thing that needed fixing. Thanks a lot!
jules- Jan 23, 2010 at 05:48 PM
omg it worked. i've been tearing my hair out for a month! thanks so much. tcp/ip is the answer!!!!!
Helpful
+15
plus moins
I had the same issue and after spending WAY too long with Acer support insisting it was my ISP or router causing the problem and that the driver was up to date I found a new driver that Acer doesnt have on their site but the manufacturer does. Installed it and it works fine now. www.atheros.cz
Helpful
+12
plus moins
I have the same problem, except that it is on my asus eee pc 701. It had been working fine until one day I could only connect to the signal (usually above 80%) but was unable to browse the net. Whenever I run firefox, google never loads and returns an error.


The problem is persisting even though it worked fine before. The computer is already 1 year old, so I hope it is only software failure, not a hardware problem. Is there anybody who knows how to solve this problem? A netbook which cannot surf the net is really annoying for me.
Grego- Feb 25, 2009 at 06:12 PM
Just bought one of these netbooks with the same problem. Only worked well wireless with the power cord plugged in, setting the network adapter power save feature to off fixed it completely. Thanx for the help.
Helpful
+10
plus moins
I had similar problem on THREE Aspire One computers...I found that if it is plugged into the power cable the internet works fine. Unplug it & oops...it stops working. It says it's connected but then it doesn't load, reset everything it thinks it's connected then drops....it's insane!

One of them we took over to a tech who said it was loaded with a virus. He removed it, charged her $35...it works now. But, we haven't tested it here today. If it works here on my wireless, we'll try to find out what exactly he did, if it doesn't, I'm going to sit in the floor & cry! haha

I'd love to know if anyone else has issues unplugged that correct themselves plugged in? Or is there some simple something I've overlooking? Please help!
williebugs- Jan 26, 2009 at 06:27 PM
Yes. My Acer Netbook connects to the Internet when plugged in but not when it is running on battery.
Helpful
+8
plus moins
To Brian...

Thank you, thank you,thank you...

I was going mad with my Aspire One. I tried everything and nothing worked. Now I can browse again...Thank you again!!!
Helpful
+6
plus moins
ive just bought my acer aspire 1 but when I connect 2 them wireless it connects but wont load the page!!! it has full signal strenth but never loads!!!! anyone no what to do???? please let me no
Courtney- Dec 30, 2008 at 11:01 AM
Did you ever find a solution to this problem? I have the same problem! its very annoying!
mecho3exo- Mar 24, 2009 at 05:21 PM
most likely because you need a wep key to access your wireless router.
John- May 2, 2009 at 03:44 PM
My Acer netbook wifi worked great until I took it on vacation. At the Miami International airport I opened the wifi and discovered the service was not free so I closed the connection. I did the same thing to the Aruba Renaissance. Once I found free connections I could not open the internet – error message not connected to the internet or invalid address. When I got home I had the same problem, using the same connection that worked fine before. I suspect that I picked up something from one of the pay for wifi connections.
Chris- May 10, 2010 at 07:22 AM
Try to browse the internet without add-ons that should work
Helpful
+5
plus moins
I have an Acer Aspire One model XG5 as well. It was working fine before connecting to my wireless internet but has stopped connecting. It shows my wireless network signal as being strong but can't connect. I tried a system restore, stopped my firewall, tried the above suggestion of turning off my Power Save mode and all that, but still no luck. Guess these Acers are pieces of junk, huh? Nothing works. HELP!!! (I'm running windows xp and have no anti-virus program anymore.) I barely have used this machine as I just got it a couple months ago and use my desktop primarily, so I'm sure I don't have a virus.
Hugo- Mar 3, 2009 at 10:35 PM
I had the same issue with my acer netbook, every thing was working fine right up to 2 days ago then I could not get the netbook to bring up my browser. I ran various virus programs and no luck. So I tried the following first I power cycled the netbook (take off your battery and unplug the unit then hit the power button a couple of times b4 putting power to the netbook). After that I powered up the machine and tried to connect and it worked with no problems. I also went into my power settings and set mt wireless card to off on the "power save mode". So far that has worked very well. the "power safe mode" options are explained further up on this page so I will not get into how to get there just follow the post above. Hope this works for you
pfigalilly- Mar 3, 2009 at 11:18 PM
Thanks for your reply, Hugo. I finally got my laptop to recognize my wireless network by unplugging my wireless router from the wall and from the desktop computer, turning off my laptop, then plugging the router back in and powering up the laptop. Lo and behold the laptop suddenly found a "new connection" with my router and I'm back in business.
Helpful
+4
plus moins
I recently bought an Acer One Aspire netbook at Dick Smith in Brisbane, Australia and encountered with a similar problem, however I had just found a solution. At first when the wireless adapter on the netbook detected my router's connection, it asked for a wep key, which at the time, I did not know what it was so I typed whatever I thought it was. Ever since then, I was able to get the correct wep key, so I clicked on the connection found, and thought that a way to re enter the new wep key was to point at the found connection, and click what showed on the left hand side 'change advanced settings'. I clicked on the second tab (I think it was wireless connection), clicked on the original connection found, right clicked, and entered the new wep key in the fields found by clicking the 2nd tab on the connection. It worked; but only temporarily as the netbook would show a 'not connected' icon even though I was able to browse on the Internet, and the connection would drop out every 5 mins. A solution to this problem , is to click 'change advanced settings' on the wireless networks window, click on the 'wireless connection' tab, and remove your main connection's router. Then, refresh for a new list of available connections, click on the main connection again, and re enter the wep key NOW and you will find that not only the icon shows as 'connected', no more dropping out occurs, and the netbook connects automatically to the Internet whenever it is switched on; pretty much permanently =-) Hope this helped. I also recommend the previous posts on turning off adapter power save mode + getting your connection right as soon as you open your new acer aspire one netbook/re do everything if you had made attempts.
Helpful
+3
plus moins
I have the same exact problem with my Aspire One I got today in Ohio??? Can't figure it out...
Helpful
+3
plus moins
Sorry guys, I know enough to be dangerous but not enough to give precise explanation but for all but the XP user in this thread try TEMPORARILY running your wireless router without WEP or switching to another security protocol (yes even try with no security but be sure to remember to turn it back on after the experiment).

After reading numerous threads and trying Kubuntu on a Dell Latitude D620 and Fedora 10 under Gnome on an Acer AspireOne I have the same problem of strong signal but either no or very little connectivity (and the little bit often drops). On some WEP networks it is fine and fast but at home (on a good/newer linksys wireless G box) I have all of these problems. One poster suggested killing NetworkManager process under Fedora (or knetworkmanager under kde) and my problems went away (after going through hoops manually configuring my wireless info). This is still a hassle - especially when I then travel to other networks where I'd prefer to be using networkmanager - my linksys can do better than wep but my wireless Tivo's can't so I'm still trying to find a better balanced solution.
Helpful
+3
plus moins
OK... so here is what fixed this problem for me. After trying and trying the different options (i.e. ipconfig release, winsockfix, disabling wireless and enabling, uninstalling norton, etc.) I decided to change my wireless router security password. In my case I have a trendnet router and my laptop as well as other wireless devices had the network pre-configure and was showing as connected, but unable to browse. After changing the password and re-joining to the wireless network and entering the new password... it worked!

Good luck.
Helpful
+2
plus moins
Try reseting the Internet Protocol (TCP/IP)
Rozalerth- Jan 10, 2009 at 04:56 PM
How do I reset my Internet Protocol?
abhi- Jun 2, 2009 at 04:18 PM
netsh I i reset resetlog.txt

use this command to reset tcp/ip
Helpful
+2
plus moins
I purchased the router yesterday and after spending all night to try to make it work and all day. Calling my Internet provider and finally Linksys . I got told that my Internet provider is the problem. Not them I will receive an phone call in the next 24-75 hours. But of course she could not tell me take it back it does not work. I finally checked on the Internet and I am not the only one with the problem. Do not by this equipment it does not work. Unless you want to spend a day trying to fix somthing which can't be fixed.
blackest- Oct 1, 2009 at 08:14 PM
sunshine you are confused this thread is about aspireone wifi card problem (which seems to be down to the os turning off the wifi card and failing to turn it back on.

Ok your router problem.
first try to connect via ethernet cable if that works then find your ip and the ip of the router. chances are the router shipped with encryption enabled you can turn it off initially or find out what settings are needed on your laptop and the shared key.

It used to be that routers shipped by default with no encryption enabled, then it became encrypted one button set ups and running an installer on your pc. The one button encrypted set ups are ok if you do precisely what it says in the instructions. Trouble is most people think you just plug it in and it works and if it doesn't its faulty

unfortunately more often than not its an inexperienced user trying to set up his first network or wireless network.
broken hardware is quite unusual unless you buy from one of the places which put returns back on the shelf.
If you have created less than five lans, I would tend to think the problem was inexperience not faulty hardware.
Helpful
+2
plus moins
I fixed mine, it is very easy...just go forget this network and then renew lease...and reconnect.... here is the link

http://support.apple.com/kb/TS1398
Helpful
+2
plus moins
My netbooks internate is not working when I look at rye internate thing the computer on the right of the screen the computer is sopost to light up ass well butt it is not lighting up only the greens wave is lighting up if you can help me t will be a pleasure
Helpful
+2
plus moins
Hi all. I also had access to my router but no internet.....frustrating

SOLUTION (simple): install the latest driver for Atheros:

Wireless LAN_Atheros_7.6.1.221_XPx86_A

http://www.acer.nl/ac/nl/NL/content/drivers

Keep checking the latest drivers that will run on your OS.

Thanks everyone for all the previous posts, it helped me find the solution.
Helpful
+1
plus moins
its sounds like all of ur wireless card have failed just happened to my brother. I you wipe ur drive and reinstall the operating system and ur computer wont recognize the device its time to go get a new card
J- Mar 3, 2010 at 10:43 PM
I'm guessing this is not the case with many. I've got a dual-boot set up with XP and Ubuntu..On XP my card works fine. In linux, just like everyone else, I can connect but not browse.
Helpful
+1
plus moins
How ironic is it, that I had to surf the internet in order to find an answer to the question of why I couldn't get on the internet? Anyway, go to http://www.snapfiles.com/get/winsockxpfix.html and download the winsock fix tool. Save it to your desktop. Click run. Reboot. Fixed my problem in less than two minutes.
1 2 3 Next

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!