I cannot access my pen drive, how to recover ? [Solved/Closed]

Ask a question lawrence - Last answered on Mar 10, 2013 at 05:58 PM by rajib
Got a transcend pen drive 4gb when connecting to usb port light blinks on the pen drive even shows in my computer after double clicking it says insert disk in dive j please help how can I recover my data from the pen drive is my pendrive damaged?
plus moins
hello friends........
here's the way to format yr unrecognized or corrupted transcend pen-drive
1. go to this site
2. download the on-line recovery tool according to yr need.
3. install it and plug yr pen-drive and run that software

its the solution through which I recovered my 3 unrecognized and corrupted transcend pen-drive.
try it ......... least your pen-drive light should blink and its drive should be detected no matter whether it opens.....
Was this answer helpful?  
sangee4554 1Posts Thursday November 8, 2012Registration date November 8, 2012 Last seen - Nov 8, 2012 at 06:32 AM
i want to know if it works well for transcend pendrives only or for other pendrives also......???
milenko- Nov 8, 2012 at 10:57 AM
only pen-drives =o(
Rajeev- Dec 15, 2012 at 04:51 AM
Thanks a lot dude... Appreciate your good work..
venkat- Dec 26, 2012 at 02:25 AM
superb... I got my files back... thank u sonu
rajib- Mar 10, 2013 at 05:58 PM
thnk worked :)
plus moins
Hi there bud.

I'll gladly help you, but do me a favor, and any of you who find this information useful too.

Click the little thumbs up next to my name to let the forum know my post is useful please!

Alright, firstly let me supply you with the AutoPlay Repair Wizard

I'd suggest you download and use the 'Autoplay Repair Wizard'
and then format the pen drive before assuming that it's time to consider a system format and fresh start.

So after you've repaired it's autoplay, (or set it to work as a plain old pendrive) you can copy off your files and format it clean.

Good luck!
crazzzzzzy guy- Jan 16, 2009 at 10:02 PM
hi,I have a 2 gb transcend pen drive. my pen drive doesnt even show the blue light when connected to the usb port.What shoulld I do? if u have the answer plz send it to my email address.
plus moins
hi. btw i'm christian I also experienced this kind of problem but I solved it by doing like this! just follow my steps!

START>Control Panel>Folder Options>View Tab>at the Advanced Settings find "Hidden Files and Folder">Click on Show hidden files and folder! then try opening again your transcend Flash Drive.

Hope I help you with post! :D

Have a nice day!

- xTiaN -
plus moins
i also faced the same problem
"Got a transcend pen drive 4gb when connecting to usb port light blinks on the pen drive even shows in my computer after double clicking it says insert disk in dive j please help how can I recover my data from the pen drive is my pendrive damaged?"
this is not a problem of pen drive, first u check that r u install any virtual drive software like Ultra ISO, nero virtual image drive etc........ if yes

first uninstall that software -> shutdown insert the pendrive and on the system then try to open..
after doing this process u may be access your pendrive...
i also done this now i'm able to use my pendrive.......... all d best..............
rave12- Jan 30, 2009 at 12:13 AM
hey buddy..could u please elaborate n explain the step u managed to get ur pen drive working again. I dint understan wat u said...uninstall virtual software n all.
lakshman kumar- Jun 2, 2009 at 03:30 AM
even after removing nero drive I cant access my pen drive..still showing insert disk in I:
anand- Jul 25, 2009 at 01:38 AM
My pen drive has 4 GB of Toshiba company and can't show in hard disk How can be possible for solving problem. Please suggest me
Thank you
regards Anand Kumar Dwivedi
plus moins
This has worked for me on a number of computers with the problem of a USB flash drive not showing up or showing up and showing the "access denied" msg. Simple solution:

Remove all usb drives. Reboot computer. Log back in. Go to services and do the following:
1. Find the "Removable Storage" service.
2. Change it to manual.
3. Stop the service.
4. Reboot and log back in.
5. Plug your flash drive back in to a USB port.
You should now not only see it, but it will be accessible and useful for storage.
plus moins
Hey even I had a problem with my pen drive, I could see the icon but every time I tried to open it, it said "Access is denied"... Thankfully the problem is fixed now.. what I did is copy pasted the data of pen drive in "my documents" (just right click on icon of pen drive, click "copy" then "paste" it in "My documents") after this format your pen drive(right click, select "format" then check on "quick format")....
now u can use your pen drive again.... hope this helps
plus moins
if none of those solutions work, try the directions posted on this forum by demonica61. I had the exact same problem and his/her instructions solved my problem instantly. good luck!
plus moins
first go to My Computer then plug in you flash drive then you will see a removeable disk and figure out which is your flashdrive then right click then click on safely remove then unplug your flashdrive then plug in again the you sholud see your flash drive.

Hope it help
plus moins
Having the same problem with the same brand (I put ubuntu bootable USB software on it)

I think maybe they are just dodgy usb keys?

I've tried renaming hte drive and so forth
plus moins
It works :D
plus moins
when we insert pendrive on usb port it always reply to unable to format?
plus moins
It's really simple to solve. Every pendrive comes with a drive and software embedded in it. Just open My Computer,right click and select properties. Once you have done that, select hardware tab and scroll down to usb icon and click anyone of them that has a danger icon attached to a usb icon and it works by itself.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!