Windows media center virus [Solved/Closed]

Ask a question s10user 3Posts Tuesday June 1, 2010Registration date June 2, 2010 Last seen - Last answered on Oct 20, 2012 at 02:30 AM by pbbbbbbp

How do I remove a virus that has Windows Media Center opening at start up and has also disabled the Internet and my control panel? Any help will be appreciated, thank you.

plus moins
I have resolved this problem by simple steps:

Step 1 - Download this file to run to fix regedit command:

After this step .exe file may run normally even the icon is seem Window media center file. (If not - do continously from Step 2)

Step 2 - In Run command box, type comman: Regedit

Step 3 - Open by this tree folder:
HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ FileExts \ .exe

Finally - Delete all cotents which are rellate to Window Media Center.

It must be work, I were done on Windows 7, Good Luck!

Was this answer helpful?  
s10user- Jun 21, 2010 at 09:03 AM
Thanks your help but I can't get past the first step. I don't get fix regedit command:but fix-exe-setdefault.rar Windows does not support rar files. When I try to run Bitzipper so I can use a rar file WMC opens and blocks me from running it. If you look at the log I have not been able to download any file suggested.
Ice- Jul 1, 2010 at 04:25 PM
THANX A MILLION! I'M WORKING AGAIN.. The only problem isi still hav the windows meda center icons on certain files n I dnt know howto get them back to normal.. I'm guessing re-create the shortcuts..
Loyboy- Jul 4, 2010 at 04:42 PM
Thanks a milloion also.. iv fixed mine also.
Allahabi- Oct 7, 2012 at 02:14 PM
You saved my day. Thanks a lot. I reset Windows media center from default programs. Everthing go back sto natural.
hmmm- Oct 17, 2012 at 06:18 AM
its works thanks ))))
plus moins
Hey guys...i had this very frustrating virus, and was going to do the' regedit' thing, I backed up my files to a another storage device and was going to reformat my HD and re-load Windows 7. But BEFORE I went through all THAT trouble, I was able to log off my administrator profile, go under the guest profile, and THEN use system restore once I used a administrator password.....worked great. Went back about a week and Pc is fine, gonna run Mallwarebytes just to be sure though...i hope this helps someone, It was very simple, quick, and kept me from my registry, reloading windows 7 etc etc.
plus moins

I will try my best to solve your problem.

There is an option provided in Windows 7 Media Center to run on startup every

time we turn on our computer. Maybe that option is selected which results in

opening Windows Media Center at startup.

Steps to uncheck that option :

In Windows Media Center--->click on "Settings"-->select "General"--->select

"Startup and Window Behavior"---> there we can find the option "Start Windows

Media Center when Windows starts", just uncheck that checkbox---->then click

on Save.

When it comes to Control Panel, may be it was configured to get disabled in
group policy or in registry.

To check whether the control panel was disabled from Group Policy, these are the steps :

1) Type gpedit.msc in the Search box in the Start menu --> press Enter.

2)Local Group Policy Editor will be opened--->now navigate to this location

User Configuration \ Administrative Templates

click on Control Panel at the left column.

Now at the right side you can find the option "Prohibit access to the Control Panel"--> just double click on it ---->Select "Not Configured" ---> then try logging off or restarting your PC if the changes are not affected.

To check whether the control panel was disabled from registry, these are the steps :

1)Type regedt32 in the Search box in the Start menu --> press Enter.

2)Registry Editor will be opened, now navigate to this location

HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Policies


3)Then at the right side, if you find a file named NoControlPanel, just delete that


When it comes to internet explorer, we can try resetting the internet explorer settings . Here is the link

You can find all the information.
s10user- Jun 23, 2010 at 06:25 AM
Thanks for your help. The Open WMC at start up box was not checked. I had already solved the control panel issue (see log) and I am using Firefox.
plus moins
Dear Sir,

Please consider opening the Task Manager and end all the unidentified processes and then get your computer scanned. If its seems that you can't access to the Task Manager too, please consider logging in safe mode and carry out the task.

Thanks in advance.
s10user 3Posts Tuesday June 1, 2010Registration date June 2, 2010 Last seen - Jun 2, 2010 at 09:06 AM
Thanks for your advice but the virus is in safe mode too.
s10user 3Posts Tuesday June 1, 2010Registration date June 2, 2010 Last seen - Jun 2, 2010 at 09:48 AM
OK I got the task manager to run. The only processes that are there are ctfmon.exe, csrss.exe, explorer.exe, taskmgr.exe, and winlogon.exe. Please advise what to do next. Thanks
plus moins
Using DOS Prompt, go to "<system drive>:\windows\syswow64" folder. E.g. c:\windows\syswow64
Type "dir /p" and check if the file adbcnsl.exe is listed. If file not found try checking c:\windows\system32
If listed type "del adbcnsl.exe".
Goto Task Manager, Switch to "Processes" tab, click "Show processes from all users" button.
Locate "stdrt.exe" process, right click and select "Properties" menu.
In the properties window, make note of the "Location" in "General" tab.
Now kill that process.
Open the location where "stdrt.exe" is located and delete the file "stdrt.exe". Sometime it can be found under multiple folder inside temp folder starting with "mprt_".
Goto registry editor and search for "stdrt.exe", delete all the keys which contain that entry.
Now restart the machine and you should not be able to see the "stdrt" process.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!