Report

“the disk is write protected” [Solved/Closed]

Ask a question bas55 8Posts Thursday October 16, 2008Registration date May 12, 2009 Last seen - Last answered on Oct 4, 2010 at 11:57 PM by khaya
Hi,

I have a Dell laptop with Windows Vista. I have recently bought an external HDD. The problem is that when I try to save anything on it, it says: "the disk is write protected"
So I right-clicked on the drive and went to "properties" > "security" > "advanced" > "owner" and whenever I try to change the owner to my username it does not allow me!
The current owner is; Administrators but when I try to change it to my username I get this message:
"Unable to set owner on local disk"

Won't I be able to use the drive?

Please help!
See more 
Helpful
+16
plus moins
If done meticulously, this works :

The Disk is write-protected” problem Run Registry Editor (regedit). Navigate to the following registry key:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control Right click on control and create new key. Name it as StorageDevicePolicies . (Copy and paste it from here if possible) Now click on StorageDevicePolicies and in right side pan right click and select create new dword and name it as WriteProtect. Double click on it and set its value to 0. Now restart your machine and try copying some files to your card
Was this answer helpful?  
pasky- Jan 26, 2010 at 02:08 AM
your great man, thank you so much you did help me, godbless
sandy- Apr 12, 2010 at 10:09 PM
xcellent man
ajf1515- Jun 8, 2010 at 02:11 PM
Thank you
khaya- Oct 4, 2010 at 11:57 PM
Thanks man, you are my hero!!!
Helpful
+6
plus moins
I somehow went on control panel, then i went on computer management, then storage then diskk defragmentor, finally i analyzed, and defreagemnted, wait 4 mins to defagment then stop and it should work :)

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!