Ask a question Report

Monitor blank with blinking power light

tomf567 - Latest answer on Dec 26, 2010 06:42AM
I have a Gateway GT 5458E running Vista Home premium with Service Pack 2. AMD Athlon 64 x 2 Dual Core 4600" 2.4 GHz, 1.0 GB RAM, 32-bit system with a Gateway Model 900W flat screen monitor.
Recently the monitor quit working. When plugged into a power outlet, the on/off light blinks slowly. Usually, is is a steady blue with powered on, and a steady yellow when in sleep mode. I can't get it to power down, and it stays blank and blinking no matter whether the computer is on or off when you hook the video cable up to is
I have tried the monitor on a different computer (running XP), and it works fine, and have tried another flatscreen monitor on the Gateway computer, and that works fine also. I have also switched the video cables.
Why won't the monitor work with the computer that it has been connected to for three years, but works with another computer, and other monitors work with this computer?
Any suggestions would be appreciated.
Read more 

moins plus

Try this 1.

If you notice that your CPU fan is running but there is no display on the screen,

then remove the RAM from the slot, clean it and place it back properly or try

another slot. Check your RAM also. Even bad RAM will result in display problem.

Good Luck.
Add comment
This document entitled « Monitor blank with blinking power light » from CCM ( is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.