Photoshop CS3 can't open RAW files [Solved/Closed]

Ask a question Girl In Purple 2Posts Saturday January 17, 2009Registration date January 19, 2009 Last seen - Last answered on May 3, 2013 at 05:41 AM by wave
Heyyy ,

i've downloaded photoshop CS3 and i'm using canon EOS 450D

i've been trying to edit RAW pictures using photoshop ofcourse .. but they didn't open

i downloaded the camera raw 3.7 software and followed all the downloading instructions on this page:

but it didn't work also .. and when I try to open a RAW picture in photoshop CS3 I get this message : could not complete your request because it is not the right kind of document "

I would really appreciate if someone would give a reason why this happened

plus moins
Follow the same instructions, just use the latest camera raw plug-in for CS3 instead!

Camera Raw 4.6 update

Was this answer helpful?  
plus moins
Download Adobe Camera Raw Plug-In 4.1.1

Here are the directions I followed to install the Adobe Camera Raw Plug-In 4.1.1:

To install with Adobe Creative Suite 3 or Photoshop CS3:
1. Exit Photoshop CS3.
2. Open My Computer.
3. Double-click Local Disk (C:).
4. Navigate to: c:\Program Files\Common Files\Adobe\Plug-Ins\CS3\File Formats
5. Move the existing Camera Raw.8bi plug-in to another location (for example, a new folder on your desktop). Ensure you keep this version in case you need to revert back.
6. Copy the Camera Raw plug-in, Camera Raw.8bi, from the download into the same folder as in step 4.
7. Launch Photoshop CS3 or Adobe Bridge.

Note: If generic camera thumbnails appear in Adobe Bridge, follow these steps:

1. Check to make sure the plug-in was installed in the correct directory in step 4 above.
2. Start Bridge.
3. Choose Tools > Cache > Purge Central Cache.

OK. Now, I can open the .CR2 Raw files in Adobe Photoshop CS3.
Liza- Sep 14, 2009 at 04:19 PM
Thanks so much. That worked perfectly! Most grateful.
ravi- Dec 25, 2012 at 12:21 PM
Thanks - its quite old post, yet quite helpful even today
kjc- Feb 7, 2013 at 08:51 AM
Thank you works like a dream
sushant- Feb 17, 2013 at 07:51 PM
not working for me :(
when I double click it in the bridge, it opens up in PS, saying...
"not a right kind of document, cant open"
wave- May 3, 2013 at 05:41 AM
same here... :(
plus moins
Almost every forum i've looked on, has had the same stuff... here's something that I used, and it worked! I've been working on the same problem for a few days (using CS2).

go here... and select the the OS youre running on the right

the link provided below is an explination/directions for the fix. It's called Adobe DNG converter. Different brands of cameras hold a different RAW format. The DNG converter will convert all RAW files to Adobe's Default RAW format (.dng).

When I used this, I went from 15 MB files to 26 MB. it's larger, but the link above will explain why, it works!

stress- Apr 11, 2009 at 03:24 PM
mmmmm well I have Photoshop 7 and just upgraded from a Nikon D50 to a D90 and now cannot open RAW files, I downloaded the converter, and still cannot open the files, I get an error message saying wrong type of files. I'm NOT a super technical person and getting very stressed as I have so much work to do......have I got to upgrade my photoshop?
plus moins
I couldn't find Adobe Camera Raw Plug-In 4.1.1, only got Camera Raw 5.5.
I followed your steps but I didn't see any "Camera Raw.8bi" in File Formats so I added the new "Camera Raw.8bi" I downloaded in to it. Then I still cannot open CRW files (I have Canon S5IS and use CHDK to take RAW). Please help. Thanks so much ^_^
plus moins
Thank you so much, the info at the top of the page work perfectly for me. :) Solved a very troubling problem. All of Adobe's featured downloads are for newer versions now, so I had a little bit of trouble finding the version for cs3, I found that the easiest way to find it was to simply Google "camera raw for cs3" and then look for the one from Adobe. Thanks for all of the help!
plus moins
I cannot find the folder C:\Program Files\Common Files\Adobe\Plug-Ins\CS3\File Formats.

I installed the Adobe suite to my D drive but cannot find it in D as well.

The only folder I get in C:\Program Files\Common Files\Adobe is SavedFonts. I tried creating the rest (Plug-Ins>CS3>File Formats) but it still doesn't work. Any ideas?
plus moins
I followed all the steps and made sure that the plug-in is copied in the right folder
and when I lauch adobe bridge and go to :
Tools > Cache > I get 2 options : build cache for subfolders and build cache for folder "desktop" !

theres not "Purge Central Cache" and I still can't open CR2 raw files
scribble1- Feb 18, 2009 at 08:12 AM
Try copying your Camera Raw.8bi fille into the program files/adobe/bridge/plugins folder. I had the same problem with .NEF file and that fixed it for me.
cannon 1000d beginner- Mar 19, 2009 at 05:35 PM
i tried all of the above but still dont seem to be able to open raw files, I just get a generic thumbnail and cant open them.

got a bit confused with

step "6. Copy the Camera Raw plug-in, Camera Raw.8bi, from the download into the same folder as in step 4."

didnt know where this file was so typed it into the search and found a file which looed the same??? gar im confused please help?

plus moins
Thanks. The info in the beginning of the topic worked perfectly!
plus moins
thanks man, very useful and simple step by step guide.
plus moins
Works perfect!!! Thanks!
plus moins
Worked perfectly! Thanks so much, saved a lot of time for batch image processing! :)
plus moins
Thanks very much for the advice xpcman. It worked perfectly. However, there is one problem - I have the generic thumbnail issue and the option for 'purge central cache' is disabled (greyed out). I have googled and havent found another solution for this problem. Does anyone know another solution since I cant purge the central cache?

Thanks in advance.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!