All desktop icons changed into .lnk file [Solved/Closed]

devanisapana 1 Posts Wednesday November 21, 2012Registration date November 22, 2012 Last seen - Nov 22, 2012 at 05:47 AM - Latest reply:  Ayoba
- Feb 22, 2018 at 03:17 AM
Hello, My problem is not solved

My problem which I give 2 days ago was not solved software rstassosiation I have installed but it described error file was not found or matched please give me another solution

See more 

18 replies

mfarooqkk 1 Posts Tuesday April 30, 2013Registration date April 30, 2013 Last seen - Apr 30, 2013 at 05:55 PM
Here is the solution.
change all the icons with, open with explorer. when all icons on your desktop changed to internet explorer, then follow the below steps.

1.go to start menu. command
3.regedit in run command.
4.HKEY_CURRENT_USER\\software\microsoft\windows\currentvershion\explorer\fileExts\ for .lnk ext.
6.delete hole .lnk key or delete the userchioce key on that.
7 just restart.
it will definitely work.
Thanks alot ,it really work very well.....
Thank you sooooooo much :)
Zohaib R 2416 Posts Sunday September 23, 2012Registration date November 12, 2017 Last seen - Nov 22, 2012 at 12:39 PM
Hi devanisapana,

Try the resolution in the below mentioned link and see if this fixes the issue:

Note: The fix in the above link requires Windows Registry editing. Always make a backup of the Windows Registry before you modify any settings. For steps on how to backup Windows Registry check this:

Do reply with results.
For Android user , delete .ink files easily . Step 1 ) You need rooted device . Step 2) You need SD Maid pro (root) . Step 3 ) Download nd install nd open sd maid pro . Step 4 ) Open Sd maid go to Explorer . Step 5) now you will see all folders nd files in memory card just select .ink files nd delete . Thats all :)