Firefox and IE Destroyed after virus. Help :( [Solved/Closed]

Dusty K 2 Posts Thursday February 12, 2009Registration date February 14, 2009 Last seen - Feb 13, 2009 at 08:41 AM - Latest reply: leomartintsa 1 Posts Friday May 17, 2013Registration date May 18, 2013 Last seen
- May 18, 2013 at 12:26 AM
Hello everyone, so let me explain how this happened, I got home from work one day and the g/f had accidentally downloaded a trio of trojan worms - Between a combination of msconfig, safe mode, and AVG I was successfully able to nullify the virus, it doesn't run anymore - This I am very confident of.

The problem is that Mozilla Firefox and Internet Explorer don't really function anymore, or I don't trust them enough to use them anymore. The problem is difficult to describe, but random elements of certain pages refuse to load. Sometimes entire pages do not load. Any sort've Flash interface seems to not function. It could be javascript also. Running Firefox in safe mode does nothing.

I figured a picture might help describe the problem more accurately, currently one of the most busted sites is Penny Arcade. Firefox and Internet Explorer both make the website look like this:

http://kwix.shackspace.com/firefoxbroke.JPG

I also happen to have Google Chrome installed - and the strange thing is that Chrome works like a charm and was obviously unaffected by these viruses. What I want to know is there anyway of repairing my Firefox and IE back to a stable running condition? I mean - I could just use Chrome now, but i'd rather use the browser I enjoy using. I've already tried reinstalling both of these applications with 0 effect. Could this be caused by some sort've registry edit? Perhaps there is something else I can do to help discover exactly what is wrong with them? Any info you guys can give me on what I might be able to do to fix these two applications would be huge. Thanks. I know that it might not be either of them, there are tons of mini apps that get installed as you browse - things like javascript and flash and I worry that perhaps one of them is busted now, but if thats true then why does Chrome work?

Again - any help would be huge. Thanks guys.
See more 

118 replies

0
Helpful
1
Thanks for the help. My Uncle who is a computer repair guy, said that I need a new Ethernet PCI Card to get it back up and running. I dont know if it will do the trick but if it dosent im gonna come back here and ask you again. haha. Thanks
Okay, however pinging the loopback ip address 127.0.0.1 will tell you if you ethernet card is sending and receiving packets. If you receive a reply, the card is working.
0
Helpful
7
How do I ping the loopback ip address?
speed_rs > Shellipe - Dec 5, 2009 at 11:57 AM
Shellipe is a genius!!!!!!!!!!!!!!!!!! Thankyou
Thank you very much, Shellipe. Got my IE running from just following your advice.
em ma laptop went pro per dogy I added this system security thing and wennt bust it proper annoing cause msn microsoft and all dont work but internet does
shellipe, you are awesome my Man
HI Shellipe, you are awsome!!!! This was hair pulling for me to get IF and FF to get to work after removing virus. Your trick did it. thanks a lot man
0
Helpful
1
I thought I answered this a long time ago. Go to start menu, Run type cmd in the run box and when the black DOS screen opens, type ping 127.0.0.1. If it says reply from 127.0.0.1 then your ethernet card is working fine.
I tried your suggestion and others in other forums but still no joy...
what should I do ?..my IE64 works but the others dont even ym is affected..
it wont connect I did the proxy setting, the winsock, and uninstalling my norton antivirus..
i've been doing this for a week now...
pls help me?...
0
Helpful
1
i tried your suggestion and others in other forums but still no joy...
what should I do ?..my IE64 works but the others dont even ym is affected..
it wont connect I did the proxy setting, the winsock, and uninstalling my norton antivirus..
i've been doing this for a week now...
pls help me?...
Like I referred Troy to, please make sure the virus is gone by trying all of the steps in #25. Sometimes you have to run the antivirus files once or twice each. I do. I run Malware bytes first then super anti spyware then security manager, the super anti spyware again over and over until it comes clean. Repairing the damage is difficult without having the computer in front of me. Can you provide more detail. Ie6 works, why not use 7 and is ym yahoo messenger???
ThatKidThatNeedsHelpWithHisBrowser:) - Oct 14, 2009 at 08:36 AM
0
Helpful
I have the same problem, whats happening is that internet explorer and fire fox is not loading any pages and when I startup my computer and open fire fox my anti virus (eset smart security 4) says that it blocked a couple of websites.
0
Helpful
Thanks, the inetwiz.exe worked for me aswell.
0
Helpful
Shellipe you are awsome.. I spent hours and hours trying to fix my internet connection after an infection with a a nasty Trojan..I almost gave up..then I stumbled upon this site and voila.. you made my day..Thank you SO MUCH...
0
Helpful
I have a similar problem. I got a trojan on my Acer which runs vista, for a while then it began not allowing me access to the internet through wireless or using my cable. Well so I began manually giving it an IP which worked til it wouldn't allow me to connect at all. I can connect at work using my laptop through either wireless or cable but in my dorm it wont do either. I have used SUPERantispyware, Malwarebytes and Symantec Endpoint Protection to get rid of the virus and Hotebar.com homepage problem but I still cant connect using my schools wireless or cable. I have also tried the suggested solutions which haven't help either.

Thanks
jystarscream - Jan 23, 2010 at 02:29 AM
0
Helpful
Shellipe thank you for your help, saved me hours of work. God bless
0
Helpful
Shellipe you are the greatest. After spending hours removing a virus - IE wouldn't work. Your instructions saved me. Thanks a million
Good for a minute... - Feb 12, 2010 at 09:44 PM
0
Helpful
Shellipe,

I had a similar problem to the start of this post, and it seems like your advise worked for me to get reconnected to IE once malwarebytes, superspyware and spywareblaster removed my trojans. However, now my computer will run well for about 5-15 minutes, then whatever I am running at that moment will freeze, so the only thing I can control is the mouse pointer. Then if I click the mouse or any keys a few times, the pointer will freeze, and my computer makes a horrible tone like I have a stuck key. The onl way to make it stop is to turn it off. I can keep it going in safe mode, which is how I was able to keep it on long enough to run the programs that removed the viruses/spyware. Any help would realy be appreciated. Thanks in advance.
0
Helpful
Hi, I have a Aspire Acer AX1200-U17110 and Im running under windows vista.
I was hit by the Vista AntiVirus Pro (Didnt say 2009 or 2010) yesterday and I used Malwarebytes and SuperAntiSpyware to get rid of the viruses. But I followed the instructions by going to IE>Tools>Internet Options>Connections>Lan Setting> And my proxy is already unchecked. I still cant go into the net. :( I really need help. I was told to go to task manager toa see the following files in process tab;

av2009.exe , antivirus2009.exe, svchast.exe

All 3 of these arent shown since I probably use use Malwarebytes and Superantispyware first. I do not know if there are any more in there. No antivirus was running.

I really need help. Its driving me crazy. I don't know what to do. :(
0
Helpful
Don't know how relevant this is but I thought I had a problem when my firefox browser wouldn't open. What I did:

I right clicked on my firfox icon shortcut to open up properties.

Under the Shortcut tab I have:
-start in:
-shortcut key:
-Run
-comments:

Under 'Run,' it has 3 options I chose maximise...Bingo! Try it before u do anything else elaborate.
0
Helpful
1
Hi Y'all
This was a real headache for me trying to fix my mates laptop after he D/L the system security 2010 virus/ Malware.
Once rid of the virus, using spyware doctor, I could not get any browser connection although it was conected and updating etc, they would be fine in safe mode too.
Eventually I just wanted rid of Anything NORTON on it, so had to D/L their removal tool, ran that removed all Noton Rot and now hey presto, all browsers are fine.
WARNING: If you use anything Norton you must be raving insane, Steer well clear or face the consequences. It is itself a legal virus.
Use Microsofts FREE AV, or if you aren't rich enough to be able to afford a legit copy of Windows, use AVG Free, or Avasts Free AV
Bindy
Ambucias 48856 Posts Monday February 1, 2010Registration dateModeratorStatus January 20, 2018 Last seen - May 5, 2010 at 04:56 AM
Hello Bindy,

Your message is kind of in the wrong thread, but I totally agree with you about Norton and all of Symantec's product; and if your system gets infected by a virus Norton was supposed to protect you against (protection for which you paid for) Norton will charge you $100 US to help you desinfect your system.
0
Helpful
1
I appreciate all of the wonderful comments but after shellpe'sgroupie, I hate to dissappoint you but I'm 100% girl. Don't know why everyone assumed I was a man. That one made me laugh though. Luv ya all!
Ambucias 48856 Posts Monday February 1, 2010Registration dateModeratorStatus January 20, 2018 Last seen - May 6, 2010 at 04:34 PM
Hello Shellipe,

Well, what do you know, they have all been had except me.
0
Helpful
hi friend,
I faced a similar problem like u,after effecting from viruses,,they mal functioned some of the functionalities in the system,,,,its better to format the system,,,,
0
Helpful
Hey thanks after booting in safe mode and using regedit @ command lines and deleting numerous AVSoft folder and even HKEY's ----- I still could not get Firefox (& seldom used IE) load, but Outlook would connect. Running Godzilla Fix seemed to do the job for both browsers.
leomartintsa 1 Posts Friday May 17, 2013Registration date May 18, 2013 Last seen - May 18, 2013 at 12:26 AM
0
Helpful
** I got my issue solved **

I had the same issue and I have solved my problem with help of this below article, hopefully this will help for you.
Click here
http://www.techsupportall.com/file-contained-a-virus-and-was-deleted/
lucas231 6 Posts Friday January 2, 2009Registration date June 3, 2009 Last seen - Feb 14, 2009 at 02:43 AM
-1
Helpful
hi,
try this link to get information about complete uninstallation of firefox:
http://support.mozilla.com/en-US/kb/Uninstalling+Firefox
try the same with the IE.
Please Help - May 31, 2009 at 11:41 AM
-1
Helpful
and I also used malware which got rid of the virus files I think but it hasnt sorted the fact that I can't open the browsers and that the computers restarts when I try to install certain programs
Firefox and IE Destroyed after virus. Help :( - page 1
Firefox and IE Destroyed after virus. Help :( - page 3