Report

Western Digital 1TB External Hard Drive Not Recognized by PC [Solved/Closed]

Ask a question jazzed17 1Posts Saturday March 9, 2013Registration date March 9, 2013 Last seen - Last answered on Mar 19, 2017 at 05:39 PM by hama kalary
Hello,

I have a WD 1TB external hard drive, supposed new without documentation. The light comes on and there are soft noises from within, but when I connect to my laptop, the drive is not recognized. There is no USB device acknowledgement of new device found. The drive does not show in the device manager or through My Computer. I am running XP with SP3 on an older Dell Latitude D620. I saw an earlier response that involves modifying the registry, but I am very hesitant to do that because of past registry problems on a different PC.

I tried downloading a driver from WD, but it will not install. I tried that several more times with the same result. I changed the USB cable with no result. It could be that I got suckered on buying a defective drive, but a quick check on Google shows this is a very common problem with WD external drives and there are hundreds of suggested fixes. I am an average user with average technical skills, and this one has me stumped. Any suggestions will be greatly appreciated!
See more 
Helpful
+89
plus moins
Solution
*Click on Start --> Run ---> type diskmgmt.msc and click on OK
*Right-click on WD Passport Drive --> Select "Change Drive Letter and Paths..." --->
*Click on "Add" button ---> Select your drive letter and click on OK
*Note : If the drive letter is already assigned, then try changing the drive letter by clicking on the "Change" button instead of "Add" button in the above step
*If the problem still persists:
*Click on Start --> Run --> type regedt32 and click on OK
*Registry Editor will be opened
*First backup your registry by going to File --> Export
*Then expand the following key:
*HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967- E325-11CE-BFC1-08002BE10318}
*If you see any upperfilter or lowerfilters entries at the right side, simply delete them.
*Close the registry and restart your PC.
Adi- Sep 12, 2014 at 06:37 AM
Thank you very much. Assigning the letter for the drive itself fixed for me.
Perth- Sep 12, 2014 at 08:26 AM
Sorted.!! Good Tips my friend. It works 100% as good as before.
maybahag 1Posts Tuesday October 28, 2014Registration date October 28, 2014 Last seen - Oct 28, 2014 at 11:28 AM
Hi Diggi!
I tried the solution you suggested here. However, there's no "Change Drive Letter... nor "Add" upon right clicking.
Upon opening the diskmgmt.msc, a pop-up window says "You must initialize a disk before Logical Disk Mngt can access it"
And at the bottom, DISK 2 says, "unknown/ not initialized"
Although upon right click and properties, the name of the HDD (My Book) may be read...
Thanks in advance!
hama kalary- Mar 19, 2017 at 05:39 PM
Thank you Bro it was helpful
Reply
Helpful
+6
plus moins
I was able to get around this issue by taking the WD Drive Manager service and making it a Manual operation, instead of Automatic. You can always try this out. I have 2 different WD drives a Passport and a My Book, the My Book was unrecognized when I added the Passport. Took me quite a while to find the issue on my PC, turning off the WD Drive Manager service and let Windows handle it. Best of luck on this.
Helpful
+5
plus moins
Hi, jazzed17

Could you please provide me with the model number of your WD external, so that I can be more specific while trying to help? You can check in BIOS to see if the drive is recognized there. You mentioned that the installation of the WD drivers failed. Could you give me some more details about that? About those sounds, coming from the drive, could you describe them as sounds from the spinning or is it more like scratching?
I would not suggest you to modify anything on your system before confirming that your drive is working fine. Have you tried the drive on another PC?

http://docs.oracle.com/cd/E19871-01/820-5830-13/app_bios.html - here you can find more details about BIOS.

Hope this helps
reen- Oct 12, 2014 at 06:22 AM
Hello,
I have purchased WD 1TB external hard drive I used it for one year and all of sudden it got problem like it couldnt be detect to my pc or laptop I could hear some noice like the hard drive is running I could see light also..i dont want to loose my data as it contains my study material how could I over come this problem...Can u please help me out with your valuable suggestions... and also I did try at other pc or laptop.. same thing happen..
R2D2_WD 3616Posts Monday September 1, 2014Registration date Certified CCM ContributorStatus February 20, 2017 Last seen - Oct 13, 2014 at 05:15 AM
Hi, reen

It is a good sign that the drive is spinning and the light is on. Is the drive visible in Disk Management and Device Manager? Try uninstalling the old drivers from Device Manager and let the drive install them automatically after a reboot. If that does not help, I would try to download any latest firmware updates from the WD web page. I leave you a link below. Check the drive with another USB cable.

http://support.wdc.com/product/download.asp - WD downloads section

Hope this helps
Helpful
+4
plus moins
I have the same problem on my 750GB Western Digital, i.e. external hard drive not recognized when plugged-in. Did try connecting it to Vista and Windows 7 and both times it failed even after installing updated drivers from WD website. Finally, I tried using Ubuntu that is installed in the same laptop with Vista and immediately the external drive is detected even showing WD logo. Now I am backing up my files again to my new portable drive, WD passport.

I've read a lot of thread about this kind of problem and did not find any fix from anyone using Windows. Luckily I have Ubuntu installed in my pc and as always have come to the rescue once again. I hope this helps.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!