Report

External Hard Drive not working in USB 2.0 Ports [Solved/Closed]

Ask a question oneputt 1Posts Friday February 7, 2014Registration date February 7, 2014 Last seen - Last answered on Feb 14, 2017 at 02:42 AM by Sekica
My External Hard Drive is a Sony HD-E1. It uses a USB 3.0 cable. I have been using it for nearly a year now on my laptop and TV with no issues and both only have USB 2.0 Ports. Recently it has stopped working on both devices. My laptop says all my USB drivers are up to date. I tried the Hard Drive with 2 other laptops that have both 2.0 and 3.0 usb ports. The Hard Drive was recognised and working without any problems in the 3.0 ports but did not on the 2.0 ports. Can anyone help me with this issue or an expaination as to why this would happen.

Thank You
See more 
Helpful
+5
plus moins
A USB 3.0 port supplies more power than the 2.0 version. It's possible the hard drive is getting older and now requires move power than the 2.0 port can provide.
Was this answer helpful?  
Sekica- Feb 14, 2017 at 02:42 AM
I had the exact same problem on my WD Elements 1TB, after a couple of years it suddenly stopped working on USB 2.0 ports but working just fine on USB 3.0.

The reason was the faulty cable. When i plugged it in with friend's Transcend USB3.0 cable on my WD it worked just fine on both USB 2.0 and USB 3.0.

Hope this helps :)
Reply

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!