Can't format USB mass storage drive [Solved/Closed]

malkosas - May 27, 2008 at 07:05 PM - Latest reply:  sscharania
- Oct 21, 2012 at 12:13 PM
Hello,

I get a message telling me my USB key needs to be formatted, I click ok, try to format and I get a message saying , disk is write protected, the problem is I've been using that key for over a year with no problem, can anyone help please
See more 

53 replies

+417
Helpful
5
Hi,
try this tool:
HP USB Disk Storage Format Tool


Juraj
Was this answer helpful?  
excellent worked first time kingston traveler 8gb
Excellent the HP format utility worked perfectly on my USB Drive.

Thank-you for the tip
Thank You Very Much ......................
You are helping me................
Thanks this solved my problem.Finaly I format usb flash drive
This tool worked very well, thanks for making it avaliable.
+417
Helpful
1
I would like to share what worked for me after downloading endless software programs, to try and remove write protection
Try this one out
Just copy and past it into your Browser
http://www.apacer.com/en/support/downloads/Repair_v2.9.1.1.zip
You will have a winrar, winzip ect… pop up
Unzip to a folder on your desktop
Unzip the zip file, and with your usb flash drive plugged in, run the program
In my case the end result was format failed, I closed the program removed the usb flash drive and then plugged it back in
then windows asked me if I would like to format this device, the windows format WORKED YES YES YES BABY
The flash drive is as good as new.
I hope this helps someone.
Was this answer helpful?  
It worked. Blessings to you and your loved ones.
+416
Helpful
For USB drives:

1. Open Start -> Run...
2. type
diskmgmt.msc
and press enter
3. right click on the partition you want to format (where the letter and size is)
4. select 'Delete Partition...' and confirm
5. right mouse button in the same place and select 'Create partition'
6. select primary partition
6. select size, file format, disk letter, label etc should be all right if you leave defaults.
7. click ok

This will recreate the partition and format it in proper way. Helped me and will help to most of you if you have problem with MBR.

Good luck
+415
Helpful
3
Control Panel - Admin Tools - Disk Managment - Wizard will (Init the Disk, Assign Drive Letter, and Format)
wow man, I knew it was lack of partition considering I accidently deleted the partition when setting up xp lol. just didnt know how to set up primary partition, it was all unallocated. thanks alot, works great now
www.try2stopus.com - Oct 19, 2008 at 10:08 AM
thank you alot you was a big help matter a fact you fixed my prob not me :) I spent 3 days trying to fix it and just wow your are very good thanks alot
Dude your Disk Management trick helped me alot.. thank you very much....!!!!!
+43
Helpful
12
Some usb keys or flash drives have a little switch that locks it & makes it read only. Try looking for something like this.
worked for me, thanks a lot, now I feel stupid :)
thank you the information is helpful, God Bless you amen
Get this. I was getting this error on my 4GB MicroSD. I have been using this for a while now, but only started getting this error in the last few days. I was using a MicroSD to SD converter. I read this post and thought, no thats not my problem, I would know if my card has a switch, ive seen it a million times. I read further for an answer that may pertain to me.

I said ok and pulled it out of my pc. I noticed the SD card was not fully inserted, I pushed it back in, and then like a truck it hit me. I had a "LOCK" switch right there on the side, which was in fact in the locked position. Gosh darn it heck I'm an idiot!

BUT this was an excellent response. You stated a simple solution without being rude or cocky (unlike the guy under the name Yo, who offered no help whatsoever on any post) even though the answer turned out to be an obvious oversight.

Now, i'm looking forward to utilizing the lock switch that I never took the time to notice before. Not sure you'll ever come back to read this page since it is not login required, but thanks for the proper postage.
This works! just put it in eject it, then give it a format and bobs ur uncal.
most usb devices have a small switch besides it so as you turn it to the other side it makes it accessible, if it is not so it makes it a read only and also disk protected
+20
Helpful
1
thanks alot computer management fixed the problem it didnt have partition..now it works..
my Pen drive is formating fist Windows was unable to complete the format this error is coming
how to this problem completde
+18
Helpful
3
Try http://emea.apacer.com/en/support/downloads.asp

Keyword search: "AH320 LFormat Utility" and download it.
Dude... Eera... U are a genius... that tool worked perfectly alright for me.... too good man... rock on... keep helping...
Hi!... Eera... U are a genius... that tool worked for me.... u r such a gOOd guy... keep helping... :)
Thanks, excellent worked.
+14
Helpful
THIS WORKED FOR ME :)

CONTROL PANEL

ADMINISTRATIVE TOOLS

COMPUTER MANAGEMENT

DISC MANAGEMENT

AND CLICK ON THE PROBLEM DRIVE


AND I THINK THEN I FORMATED IT
+14
Helpful
Hey Folks: I messed up my 16GB XPORTER drive
installing a linux .img file to boot from USB PEN method

tried bunch of tools mentioned
I even did a low level format and did a FAT format under Linux .
Windows still did not recognize the drive. HP utility kept telling me it was
write protected....

What worked for me was using partition manager 9
I first assigned a DRIVE letter to the USB drive and then did a FAT32 format
after it completed and no errors reported. I then tried the HP tool
again and this time it worked!!! I was so stocked!

good luck
chepemiller - Nov 14, 2008 at 06:16 PM
+10
Helpful
I just want to say that after a year looking for answers I finally fund it. with the download posted in this site. thanks
chanderhass - Nov 8, 2008 at 06:44 AM
+8
Helpful
dear sir first of u check u login user account or administrator account or check virus in ur syytem .
+6
Helpful
guys look for HP usb format utility
IT solved my problem.Cheers..
+6
Helpful
Best link for USB format & write protected problem solved.

this link is very helpful for every one

http://www.transcendusa.com/products/online_recovery_2.asp?dw=1
+5
Helpful
hey thanks for the help !!! it seems my sd card had a little yellow swith that turn the write protection off...
you people should search for it on your usb or sd card
Afsana pyaar ka - Apr 19, 2010 at 06:46 AM
+5
Helpful
Hi I thnk this is the solution for it..
on ur usb at the side there is a small tiny button which u can make it "up/down"
just push thats small button to the other side in that usb and try it on ur p.c
+5
Helpful
In pen/flash drive write protect error can remove by some tips given by our friends in answers page.But it wont work some time,
My personal opinion and suggestion is
go to your product official website
say for transcend pen drive go to www.transcend.com
and down load formatting software,
click on the downloaded software,
it will release the protection key and formats the your pen drive.
okkkkkk...enjoy..
The Overseer - Jun 3, 2009 at 05:36 PM
+2
Helpful
Installing software directly onto the USB storage device often results in the installation program re-formatting the USB storage device, most USB storage devices run on a FAT32 format, the installation usually re-formats to the FAT format, this formatting results in loss of storage space, and/or security errors, you must re-format the USB storage device to a FAT32 format to fix the loss of storage and/or security errors, to do so, open 'my computer', right click on the storage device, click 'format...', and re-format to FAT32, if it is already FAT32, try formatting to FAT.
MITHUN MALUR - Jul 28, 2009 at 10:44 AM
+2
Helpful
1
Hi Everyone,

the link http://www.apacer.com/en/support/downloads/AH320_Utility_LFo­rmat.zip
really works for kingston usb mass storage devices..

thnaks for saring the souce..

Regards
Mithun malur
it not work too cannot find the usb
+2
Helpful
I fixed my the problem it would seem was my drive space was not allocated sd
step by step
considering the drive is conected to pc and running vista

right click my computer manage
disk
managment
then right click the unallocated drive then allocate ok this will then allocate ya drive and format it
this should be enough if you have the same problem I had

xp users use partion magic BE CAREFUL powerfull software can destroy your hdd's if you select wrong one
1 2 Next
Can't format USB mass storage drive - page 2