Report

Cannot Format or Assign a Letter to a Seagate Ext. Hard Drive [Solved/Closed]

Ask a question FlyingG 5Posts Sunday December 13, 2015Registration date December 14, 2015 Last seen - Last answered on Apr 2, 2017 at 01:23 AM by Guest
Hello,

I have just received a new Seagate External Hard drive. I have never had problems with others I have had straight from the box.
When plugging in, the computer recognises the drive as a new device but it doesn't show up in "My Computer".
It does however show in Device Manager/Computer Management in Windows XP as below. It is supposed to work with XP SP3. It is the top drive but with no letter or format showing. It is also listed at the bottom as "Disk 2"

Having looked at various guides, it's suggested either "Assign the drive a letter" or I need to format the drive to NTFS, but as can be seen below, when I right click the top line I get a greyed out options so I cannot do either.

If I right click on the lower "Disk 2" panel I get the same thing...


Therefore I am stumped. I have tried other external hard drives(which all work), updating drivers and changing the USB ports and leads.
I don't want to return the drive yet to be sent another that is exactly the same.

Any help or suggestions would be very appreciated, but please be gentle as I am not an expert:-)

Thank you
G
Edit - I did read somewhere that "GPT" is for hard drives over 2TB and this is supposed to be a 2TB one but in reality it's 1863.02 GB. I don't know if the "GPT" should read something else for sizes under 2TB?
See more 
Helpful
+0
plus moins
Just to say that I think I have found a solution here that might help others too...
http://knowledge.seagate.com/articles/en_US/FAQ/207837en?language=en_US

Tentively I will say that this problem is now solved, though it looks like it will take a long time to format to NTFS but at least I have a letter now!

Thanks for anyone that took the time to read this.
jack4rall 6525Posts Sunday June 6, 2010Registration date ModeratorStatus December 30, 2015 Last seen - Dec 14, 2015 at 12:50 AM
Thank you for coming back and posting the working solution.
FlyingG 5Posts Sunday December 13, 2015Registration date December 14, 2015 Last seen - Dec 14, 2015 at 10:44 PM
No problem jack4rall.
It's all worked out fine now. I wasn't sure how to mark this as "Solved", so if you did, then thank you.
Helpful
+0
plus moins
I had the same problem tried this and something unexpected happened that wasn't exactly what this solution was but it worked in the end. Basically I did everything up until the "clean" in diskpart and I got an error so I thought that was it but when I went back to disk management I had 4gb of allocated space so from there I was able to create a new simple volume and then format it and it gave me another error so I ejected and then plugged it back in and the formatting worked then. Hope this helps!
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!