Formated my ASUS laptop and FN keys dont work as they used to. [Solved/Closed]

Iron - Mar 9, 2016 at 11:49 AM - Latest reply: BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen
- Mar 11, 2016 at 09:38 AM
Hello, I formated my ASUS ROG PC a few weeks ago and since then the FN keys that are on my arrows pad (Stop, Play/pause, FWD and RWD) dont work as they used to.

They used to be able to control Spotify from any window by just pressing FN+key but now it doesn't even respond.

Is there a way to fix this? I'm using Windows 10.


See more 

11 replies

BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen - Mar 9, 2016 at 01:51 PM
-1
Helpful
3
Hi Iron,

You will need to install the keyboard drivers for your particular keyboard to regain this funtionality. Go to the keyboard manufaturers website to download them, or use the DVD that might have come with it when you bought it.

Please let me know how you get on.
It's a laptop. I use the keyboard that is already installed in it, so I have no CD and ASUS doesn't seem to have anywhere drivers for keyboards except for one single USB model.
BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen > Iron - Mar 9, 2016 at 07:00 PM
Oops sorry - I didnt read the title of your problem. Silly me!

Try this ... Go to Start and type: C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey\HControl.exe and press enter.

Hopefully this will do the trick.
It now opens Windows Media Player when I press Play, which I guess it means it sort of worked.

Do you know if there is any solution to this?

Thanks for your help!
BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen - Mar 10, 2016 at 05:01 PM
-1
Helpful
6
Glad that worked for you.

The new issue you face is probably because the program you want to use either isnt installed, or is not the default player. Try (re)installing the program you want to run when you press PLAY.

Please let me know how you get on.
BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen - Mar 11, 2016 at 04:19 AM
GRRRR - Silly Windows!

Try taking a look at this site - I know its for VLC player, but the concept here should be the same for your player of choice.

https://www.vlchelp.com/how-to-make-vlc-the-default-media-player-in-windows-10/

If this still wont work please let me know what program you want to open up.

Please let me know how it goes.
I'm afraid it didn't work either. What I'm trying to do is to get Spotify respondint to the Play/stop/FWD/RWD FN keys in my arrow pad. But even if I'm in the Spotify window and press Play, Windows Media Player opens up instead of playing music in Spotify.

Is it possible that maybe those keys are bind only to WMP?
BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen - Mar 11, 2016 at 07:15 AM
The research Ihave done leads me to think that Spotify doesnt use Global Keys for this sort of function in Windows. However, you could try taking a look at the website below. I dont use spotify so cant test it and I have no idea how good or accurate this site is. If you need to download anything please make sure you check it for viruses. Neither I nor CCM can be held responsible if anything goes wrong - you do this at your own risk!
hat said, here is the link ...

http://www.ghacks.net/2013/02/02/toastify-adds-global-hotkeys-to-spotifys-windows-client/

I dont think this applies to you, but ... Are you using Chrome? Chrome does tend ti Hijack a lot of shortcuts. Try this ...

You can set to the keyboard shortcuts to work only when Chrome is in focus:

Open the Chrome app menu
Select Tools > Extensions
Click the ‘Keyboard Shortcuts’ link at the bottom of the page
Find the Google Play Music section
Change any specified media key options from ‘Global’ to ‘In Chrome’

Or you can disable/remove the app/extension from Chrome entirely:

Open the Chrome app menu
Select Tools > Extensions
Find ‘Google Play Music’
Uncheck the ‘Enabled’ box OR click the trash can to remove
You're my hero!

Toastify does just what I was trying to fix, but as it can't bind hotkeys with FN I'll just use Ctl+Alt+Window+Arrows.

Thanks a lot!
BrianGreen 937 Posts Saturday January 17, 2015Registration dateModeratorStatus October 11, 2017 Last seen - Mar 11, 2016 at 09:38 AM
Glad it worked for you. (And keep spreading the word about me being a hero ... now where did I leave my cape?)