Report

JET_errFileAccessDenied [Solved]

Ask a question NeilCairns 2Posts Sunday June 5, 2016Registration date June 24, 2016 Last seen - Latest answer on Jun 24, 2016 10:39AM
Hello,
I'm trying to put a restored EDB in to a clean shutdown state (its currently saying its in a dirty shutdown state). However when I run the command I get this back;
Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after 30.93 seconds.
If I use handle.exe to show the handles for objects in use then that recovered EDB doesn’t appear in the list. The main EDB does but this recovered one (that will be part of a recovery group) doesn't.
There's no AV installed (I removed it to see whether this was causing the issue though it did have an EDB exclusion).
Any ideas what may be the cause?
See more 
Helpful
+1
moins plus
Add comment
Helpful
+0
moins plus
I think it is the log file that is locked. You might try a few things- cheating by moving the log files to another location and only leaving the essential log files or checking the properties on the log files. Or you can try to restore the file from backup. Always make a copy of your edb files before running any maintenance on them.
NeilCairns 2Posts Sunday June 5, 2016Registration date June 24, 2016 Last seen - Jun 24, 2016 10:39AM
Thank you buddy for your help and time. your recommendations are very useful. the issue is resolved.
Reply
Add comment

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.

Not a member yet?

sign-up, it takes less than a minute and it's free!