Ask a question Report

EXPLORER.EXE corrupted or infected [Solved/Closed]

DennisPS 2Posts Sunday June 1, 2008Registration date October 4, 2008 Last seen - Latest answer on Jul 13, 2013 06:30AM
Hello,
Desktop is dropping after boot. I cannot open task manager because I try but I get error message that says task manager was disabled by administrator. I have to click ok. Then I get the same problem. I cannot do a system restore because I cannot go back past the last time I tried to do it, which was two days ago. There are no more available days to restore to.
Symptoms: When I boot my pc, it comes up fine, with all the regular icons on the desktop and programs appear to be running, but then my desktop icons, and all files I might be trying to click on close down in a flash. Then they re-apear again, just to do it all over again. I managed to get to the run function to run regedit. That's as far as I want to go because I don't know where to go in regedit to find the culpret infected file to delete it. I try to run virus scan with Mcaffee, but nothing is found.
Question: Is there anywhere that I might look to find the culpret file in the regedit editor? From what I have managed to find on the Net, it involves the explorer.exe file and I don't know what to do to get to this infection, and I do not, under any circumstances, want to re-install my OS just to get rid of it. I have no back-up for all my files, I know I am a fool for not backing up my files daily, but what is done is done. Can I fix this? The pc is rendered useless without the fix or re-install. Can't I just find the infected file, delete it, and then re-establish my explorer.exe file at re-boot from the install disk or the Internet?
Question: Where is the explorer.exe file located in the registry? Can this issue be resolved without drastic measures? Please help me. All my files from over 14 classes are on that drive, and if I lose them, I have nothing to refer to for my capstone project for graduation BaSc Degree in four months. I don't know where else to turn except the Internet and you.
Thank you. DennisPS
Read more 
Answer
+417
moins plus
Here's how to fix this issue:

1. CTRL-Alt-Del to bring up Task Manager.
2. Click File | New Task(run).
3. Type regedit in the Run box and click OK.
4. Browse to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution.options

5. Under this key there will be subkeys named explorer.exe and iexplorer.exe. Delete the explorer and iexplorer keys entirely. They should not be listed under the Image File Execution.Options key.
6. Close the Registry Editor.
7. Restart the computer.

Assuming no other viruses / adware / spyware / malware are interfering, the Windows desktop should load fine now.

Thanks to Aur computer service.
Originally post by 2/9/06: SmitRem

John- Oct 30, 2012 02:47AM
Um... There aren't any subkeys of explorer.exe and iexplorer.exe... But the problem persists... Can you please explain the last bit?
chris- Nov 18, 2012 04:29AM
you must use the "run" operation

press the WIN + R

then type regedit

the it needs an administrative access then ok....

and follow her steps...
hi- Feb 27, 2013 06:08PM
i see no explorer.exe
Awais- Jun 28, 2013 11:49AM
i delete the both file but nothing happen and i face the same problem
faisal- Jul 13, 2013 06:30AM
i deleted both files and restarted my computer but the problem still exists
Answer
+59
moins plus
It's a miracle! 2 calls to Dell tech support and a pro that couldn't fix it, but this did. Thanks to the Genius that found and shared this solution

lqi7457- Nov 2, 2012 06:35AM
your luck is good
Answer
+38
moins plus
ok. I had the same problem as everyone, but I just fixed it about 2 minutes ago.

I had just deleted a bunch of malwares from my computer, and restarted it. But it still had a completely black screen with no start menu or anything.

So I opened the task manager, clicked on new task, and typed in C:\windows and clicked ok. then I just right clicked on the windows explorer icon and clicked run as administrator.

It was as simple as that, and after three seconds everything came back. ^^ hope this helps

Answer
+37
moins plus
doesn"t seem to work. theexplorer.exe and iexplorer.exe were not there.

valadis 1Posts Saturday May 4, 2013Registration date May 4, 2013 Last seen - May 4, 2013 10:46AM
yea thats also happens to me???
WHAT I CAN DO GUYS???
Answer
+27
moins plus
YOU ARE A GENIOUS! THANK YOU. IT WORKS FOR ME.

Answer
+15
moins plus
Just tried malwarebyes as well, let it do a full scan and wait for it to finish. I put it onto the jump drive, pushed control+alt+delete, and file > new task (run ...). Then just find your way to the jump drive, run the installer, and run it :)


Got a new problem now, but at least this one's fixed :P

Answer
+12
moins plus
Works perfectly...thanks a lot dude

Answer
+10
moins plus
Great info! Works like a charm!

I had a slightly different problem, but this worked!

Answer
+7
moins plus
Thaks for that professional solution

Answer
+7
moins plus
Thanks Mate!! Worked Like a charm.... ;)

Answer
+6
moins plus
incredible , i ran 4 of the best malware soft , and none of them had fix them exept malwarebyte.
great thx for the tip

Answer
+5
moins plus
Thank you very much!!! It works like a treat!

Answer
+4
moins plus
Thankyou vey much worked fine for me THANKYOU

This document entitled « EXPLORER.EXE corrupted or infected » from CCM (ccm.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.