My WD passport hard drive doesn't show on my computer even after [Closed]

Diana - Sep 29, 2016 at 08:26 PM - Latest reply: R2D2_WD 3616 Posts Monday September 1, 2014Registration dateCertified CCM ContributorStatus February 20, 2017 Last seen
- Sep 30, 2016 at 02:53 AM
Hello,


I really need help I got an WD my passport hard drive yesterday everything was going great I copied stuff and opened it on my laptop device and everything was fine until my cousin bluged it into a mac book and some window appeared to her and she didn't read it there was an allow icon but she didn't press it she just hit the (X) button and and since then the hard is not showing anymore on her MacBook when I took it and tried to open it on my device ( win 7 ) everything was going well at the very beginning the small led light was here , the hard drive sound was fine , and the hard was already installed and it showed on my control panel > hardware and sound > devices and printers but when I opened my computer to display some file My hard drive was not there it didn't show up on my computer , I tried that Cmd.exe trick nothing was solved the same problem was here what should I do ? Please i need your answer asap
See more 

1 reply

R2D2_WD 3616 Posts Monday September 1, 2014Registration dateCertified CCM ContributorStatus February 20, 2017 Last seen - Sep 30, 2016 at 02:53 AM
0
Helpful
Hi Diana,

I am sorry for any inconveniency caused by your WD drive. Please check the drive on another Windows PC and with another USB cable. Usually, the My Passport drives are preformatted in NTFS for Windows usage. If you want to use the drive on a Mac PC you need to format it. From your description I get the idea that the drive was not formatted on the MacBook and it should be in NTFS. Please open Disk Management and confirm that. Does the drive appear there and does it have a drive letter? Could you tell me what CMD commands have you tried? I would recommend you to try those:
Diskpart
List disk

The drive should be listed. If it is not there, there may be a connectivity problem. In that case, open Device Manager and uninstall the drive. Restart the PC and plug the drive back in. The OS should automatically reinstall the drivers.
If the issue continues and the drive is not working even on another PC, I would recommend you to call the seller and use warranty.

Hope this helps