Report

Problem in my otg drive

Ask a question johnny - Last answered on Oct 17, 2016 06:12AM
Hello,
I brought an sandisk 32gb otg drive at first it worked properly in my phone motog but today I copied some files from my friend's laptop then I tried to copy to my phone and it showed operation failed I formatted the disc but still I can't use the drive or copy anything in it please help me
See more 
Helpful
+0
moins plus
Hi Johnny,

So right now the pendrive is not working normally when connected to a PC, right? Could you open Disk Management and check if the drive is correctly recognized with a correct file format? If the drive is not recognized or appears with wrong file format even after formatting the drive, it may have been damaged. If the drive has a drive letter, run the Command Prompt and use the command chkdsk L: /r where L must be pendrive’s drive letter.

Hope this helps

Add comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!