Report

Having trouble accessing my WD Passport

Ask a question lilxcherry 1Posts Monday November 28, 2016Registration date November 28, 2016 Last seen - Last answered on Nov 29, 2016 at 04:19 AM
I have a WD My Passport that I've been trying to open on my Windows 7 computer. When I plug in the external drive, it shows "CD Drive WD SmartWare" in My Computer but not the removable drive where my files were stored. "My Passport 070A" also shows up in Devices & Printers as well as in my Device Manager. I also scanned the device's drive and everything is up to date.

Any idea on how I can access my removable drive files?

How it looks like in my Disk Management. Disk 1 is the WD Drive:


What happened when I tried to assign a drive to the partition:


The WD Drive doesn't show up when I tried to assign a drive to it via command prompt:
See more 
Helpful
+0
moins plus
Hi lilxcherry,

I am sorry for any inconveniency caused by your WD drive. I strongly recommend you to test it on another PC and with another USB cable. This way we will have some more information if this is an OS issue or a drive problem. If the drive is working fine on another PC, open your PC’s Device Manager and uninstall the My Passport and the USB hubs. Restart the PC and connect the My Passport drive. Do you see a driver installation process? Please run the Command Prompt as an Administrator and type the following commands:
Diskpart
List Disk

Is the drive listed there?

Hope this helps

Add comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!