Report

My external hard drive now reads g instead f [Solved/Closed]

Ask a question Houston - Last answered on May 8, 2017 at 01:35 PM by ajuna
Hello, yeah well I downloaded 2 games on to my external western digital harddrive WoW and Battleground Europe. I take my hard drive to my friends house in an attempt to show him the game when pluggin in to his old xp computer it worked so when I tried to let him try on his vista laptop it didnt work and a message popped up saying somethin about it not working. So when I take it home and plug it in to play it now shows to being a G drive instead of an F drive as it used to and it wont allow me to play the game wether I access it from the actual external hdor try to the use the desktop shortcut that let me use it before. Please help I hope what I told may help I think when pluggin into his vista it changed it path but when I go back to change it on the computer management F doesnt even show up as an option.
See more 
Helpful
+168
plus moins
it's easy to reassign the drive letters of your choice to add-on disks in Windows. Microsoft says you should log on as an administrator, and from Administrative Tools in Control Panel:

Double-click Computer Management, and then click Disk Management in the left pane.
Right-click the drive, the partition, the logical drive, or the volume that you want to assign a drive letter to, and then click Change Drive Letter and Paths.
Was this answer helpful?  
bill- Mar 13, 2013 at 06:02 PM
not clear budds!!!!!!!!!!!!!
raynechelle 8Posts Wednesday March 27, 2013Registration date August 15, 2013 Last seen - Mar 27, 2013 at 05:50 AM
please can you help me fix my problem? it's in the forum, with the subject "596.16 GB external drive but properties appears that it is only". please.....
Alina- May 6, 2013 at 12:35 PM
It worked, thanks!
marye- May 22, 2013 at 05:25 PM
solved!! you seriously rock!!!
ajuna- May 8, 2017 at 01:35 PM
Thank u so much !!
Reply
Helpful
+15
plus moins
go to your control panel, make sure your in classic view, then click on administrative tools.

Double click on computer management,
Go to Disk management (on the left)

Right click on the drive, and go to "Change Drive Letter and Partitions"

Your welcome ;)
Kriss- Oct 14, 2010 at 01:29 PM
This is excellent advice for Vista user, I knew where it was on xp, but not on vista
Helpful
+2
plus moins
It's pretty simple, even a girl could explain it. Wait, I am a girl!

Taking your harddrive out is what changed its letter, its nothing to do with using it on your friend's machine.

The assigning of drive letters to external storage devices is simple, it just assigns them any letter after the standard C for your hard drive, and D, E, F etc. for all your extra partitions, hard drives and disk drives. Then maybe G for a USB stick, and I for an external hard drive. In this example, if you remove the USB stick and restart your computer, the next time you start up, your hard drive will be a G.

If you need it to have a particular letter, do this: go on explorer, look at what now has an F by it. Say it is a USB stick. Switch off your computer. Remove The device that had the label as F, and attach your hard drive. Restart your computer. It should now be F, as desired. Now you can reattach the device that had stolen the F before, and it will become G.
Helpful
+2
plus moins
Hey, that's some great advice and I want to try it, but what if none of the drives are marked with an F? All I see a C, D, E, G, and H. Maybe I should take my hard drive and USB out and see which is normally the F?? Please help...
girl geek- Aug 21, 2009 at 11:55 AM
Yeah, just take out everything before that and put it back in in the right order so it ends up with the right one being drive F. Windows will automatically give things the next available drive letter.

Alternatively, you could reinstall the program, or find the files in the installation directory that tell it where to look for the data... and change those to the letter to which your drive is now assigned. That will be harder if you are not used to so try the first method.
JustDolphy- Oct 15, 2009 at 11:14 AM
I am having a similar problem. My music is being read from the F: Drive, which is where my external is plugged into, and I was using a flash drive in addition, recently, which I believe was being read on the G: Drive. Somehow, the F: Drive is now being read as the G: Drive and has caused my iTunes to not be able to find any of my music. I want very much to be able to go back to my computer reading the external as the F: drive.

I have tried stopping both devices, unplugging, rebooting and even if I plug just the external in, it now only reads it as the G: Drive. The oddest thing is that if I plug something else into one of the USB ports after the external is already running on the G:, it will read the new device on the F: Drive.

How do I get it back to having the external being read on the F: Drive?

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!