WD My Passport external hard drive is not accessible

Ask a question r.huisamen 1Posts Tuesday June 20, 2017Registration date June 20, 2017 Last seen - Last answered on Jun 20, 2017 at 05:18 AM by Ambucias
Good day,

I hope there's somebody out there that can help me.
First let me say, I have my child's pictures and videos of birth until now on my hard drive - formatting is not an option!*

So, the usual way to access my hard drive, I connect it via USB port. On my computer window, it appears under hard disk drives. I double click and then the drive opens up and takes me to the software - i choose to unlock the drive and the window appears and asks for password. Once password is inserted and correct, the drive automatically opens up in a new window and all my data is shown.

Now, when I connect the drive and open up my computer, the drive name appears under devices with removable storage as a CD-drive. I double click to open, the same software is there to unlock. I choose to unlock and put in password. Then it opens up under hard disk drives as a different hard drive name e.g local disk (I:).

When I double click on it, it gives an error message: I:/ is not accessible. The Parameter is incorrect.

My brother-in-law checked the drive system properties and advanced system properties. It does show as disk drive.

Your help will be much appreciated.

Kind Regards,
plus moins

Try unplugging the device, uninstalling the drivers, restarting the PC and plugging in the device. The OS should reinstall drivers. I would try the chkdsk /r, /f commands from the cmd. Some users seems to have pretty good success rate with this method. You should try accessing your files from another PC. - more about chkdsk commands - You can manually download the WD drivers.

Hope this helps
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!