Report

WD Elements 2 TB not recognized in Windows 7/10

Ask a question rvipinkumar 3Posts Friday August 4, 2017Registration date August 4, 2017 Last seen - Last answered on Aug 4, 2017 at 06:14 PM by Ambucias
Hello guys,

I am at my wits end, searching and finding a solution to this never ending problem.

I have a WD 2 TB Elements drive, which worked perfectly some 3 weeks ago. I used it as a Backup device for some important files for me.

I plugged it 2 days back to my Windows 10 x64 machine, and do whatever I may, it didn't show up in the 'My PC'. I am getting an error message: "USB device not recognized: The last USB device you connected to this computer malfunctioned". The light in front the unit remains on, and I can feel the whirring of the hard disk when touched.

I have checked if it is appearing in the Disk management MMC, but it didn't show up there either... :(

I have tried many interesting advises from the people who use WD drives, and so far I have done these steps without success:
1.) Changed the USB cable to shorter/longer/thick - No go...
2.) Deleted the Unknown Device in Device Manager and restarted the system - No go.
3.) Changed the hidden Power settings - fastboot and the other one to disable - still no go.
4.) Somewhere it is mentioned to update the AMD chipset of the laptop - No go.
5.) Installed the older WD SES driver and restarted the system - No go.
5.) I have checked the drive in Windows 7 in another laptop of a friend, but it showed up the same message there too. :(

Did I ran out of luck and Is it a faulty drive? The drive was never dropped and was always stored in a safe dry place...

Any help in this regard is much appreciated...

Thanks,
Vipin
Helpful
+0
plus moins
After plugging in the device, go to device manager (In run type "devmgmt.msc") In Device manager go to "Universal serial bus controllers" It should list the storage devices that you have connected to your PC. Right click and then click "Uninstall. Remove the USB drive and restart your system.
Try connecting the device again
rvipinkumar 3Posts Friday August 4, 2017Registration date August 4, 2017 Last seen - Aug 4, 2017 at 04:26 PM
Hello Ambucias,

I have tried that. I deleted the Yellow "Unknown USB device" and restarted the system. The drive is still not recognized.
Reply
Leave a comment
Helpful
+0
plus moins
Click on Start --> In search box, type cmd and press Enter. "Command Prompt" will be opened. Now enter the below commands

set devmgr_show_nonpresent_devices=1
and press Enter

cd \
and press Enter

cd windows\system32
and press Enter

start devmgmt.msc
and press Enter

"Device Manager" window will be opened. Now in the device manager, click on "View" --> Select "Show hidden devices".

Expand all the nodes by clicking on "+" symbol. If you find any greyed or UNKNOWN entries --> Right click on it --> Select "Uninstall".

Restart your PC --> Now try connecting your external drive.
rvipinkumar 3Posts Friday August 4, 2017Registration date August 4, 2017 Last seen - Aug 4, 2017 at 05:13 PM
Hi Ambucias, I deleted all the greyed out and Unknown entries from the Device Manager as suggested by you. But the drive is still not showing up.

However I got a "Device Setup" message as shown here: https://ibb.co/j0wMjv

-Vipin
Reply
Ambucias 45686Posts Monday February 1, 2010Registration date ModeratorStatus October 18, 2017 Last seen - Aug 4, 2017 at 06:14 PM
Hi Vipin,

Strange!

I suggest that you contact Western Digital support here:

https://support.wdc.com/index.aspx?lang=en

Good luck
Reply
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!