Outlook - Hyperlinks issues


Ask a question



You are encountering one of the following issues under Outlook:
  • Nothing happens when clicking on hyperlinks.
  • Clicking on the links will open the browser, without loading the webpage.


Several solutions are available:
The simplest solution is to configure Internet Explorer as the default browser.
  • Open "Internet Explorer", click on "Tools" then "Internet Options."
  • Go to the "Programs" tab, verify that Internet Explorer is the default Web browser.
  • Click on "Make default" then apply.
  • It is also possible to configure this option from the Control Panel.
  • Open "Add/Remove Programs", click the "Set Program Access and Defaults".
  • Go to the "Custom" tab, select the "Internet Explorer" browser, confirm with OK.

The trouble opening links may also be due to incorrect values of the "urlmon.dll" file
  • Close any running programs.
  • Click on Start > Run
  • Type "RegSvr32 urlmon.dll" and then click OK.

The following message shall be displayed: ""DllRegisterServer in urlmon.dll succeeded"
Restart the computer and check the functionality of links.
If the problem still persists, you need to repeat the operation using the following commands:
  • RegSvr32 Mshtml.dll
  • RegSvr32 Actxprxy.dll
  • RegSvr32 Oleaut32.dll
  • RegSvr32 Shell32.dll
  • RegSvr32 Shdocvw.dll
  • RegSvr32 Msjava.dll
  • RegSvr32 Browseui.dll
  • Open Internet Explorer, click on Tools then Internet Options.
  • In the "Advanced" tab, click "Reset".
  • Apply and restart the computer.

Here is a free utility called "Power IE6" designed for troubleshooting, repair and optimize Internet Explorer 6. Power IE6 can be used with Internet Explorer 7 too.
Jean-François Pillou

CCM is a leading international tech website. Our content is written in collaboration with IT experts, under the direction of Jeff Pillou, founder of CCM.net. CCM reaches more than 50 million unique visitors per month and is available in 11 languages.

Learn more about the CCM team