Computer starts, but displays nothing

Closed
mariopoke68
Posts
1
Registration date
Tuesday September 5, 2017
Status
Member
Last seen
September 5, 2017
- Updated on Sep 5, 2017 at 08:32 PM
Just to give you a preface, this occurred when I was trying reapply thermal paste on my processor. So after I reapplied the thermal paste and put the processor and heat sink back in, I got a blue screen something about UEFI unable to find a file upon rebooting. I don't know why this happened but I believe the computer was on sleep mode when I was reapplying the thermal paste.

Anyway it also gave me an option to go to my BIOS settings if I pressed ESC, to which I did. As I was looking through the settings in BIOS, it suddenly froze and I was unable to move my mouse cursor. Puzzled, I turned off my computer and now it wasn't displaying anything on the screen anymore. My mouse and keyboard lights weren't turning on, however my Blue Yeti microphone still had the red mute button light on. All the fans are still functional.

At first I thought it was the processor that went bad, but I tried changing it to another processor and still the same result. So I'm guessing maybe it has to be either the motherboard, or power supply, unless both processors somehow got fried? I tried unplugging everything and holding the power button for 30 seconds, and resetting CMOS, - nothing is working.

I don't know, this all seems so sudden especially since I was just trying to reapply thermal paste. Maybe it was a bad idea that I took out the CPU in sleep mode or something. Could you guys offer some advice? Thanks.