Fn keypress will not register at all Acer Aspire 5742z, 2nd kybd

Scottra - Jan 17, 2018 at 09:11 PM
I have an Acer 5742z with a perfectly functional keyboard, except that the Fn function key has stopped working.

The thing I have tried--
--Replaced the keyboard with a known good spare from my old 5742z.

--Uninstalled and reinstalled the Dritek/Acer Launch Manager utility

--Checked msconfig to ensure that Launch Manager is listed in startup applications. It was actually listed twice, one instance linked from the Program Files (x86) folder and one from User/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Startup Programs (or a path along those lines...)

--Tried the Windows On-Screen Keyboard and online keyboard testers. Neither register Fn key depressions.

--Check BIOS for a "Fn Enable/Disable" option. No such thing seems to be there.

So, what's left? I don't think it's the hardware, but I think somehow the key is disabled in firmware or OS? Maybe I need new keyboard drivers? Or...?

Thank you!
See more