Internet Pings but Does Not Load

Registration date
Wednesday October 3, 2012
Last seen
October 3, 2012
- Oct 3, 2012 at 10:26 AM
Hi there!

From what I've been seeing and been doing my research for the past two days, many people have been having the same issues throughout the years, however, this is the first time I've encountered this issue and many of the specific workarounds or fixes have not worked for me. I've been trying to work through this for 24 hours straight now, but to no avail so many thanks to those that can help.

I have tried the solutions from the sticky thread on this forum but none of those solutions worked for me.

On Monday night, got home from work; surfing the internet for half an hour, everything was fine as always. Just after half an hour, my Internet got very sluggish and then it died completely. I thought it might have been the an update I just put through in terms of Windows Update that said was a critical update for MSE, as the same thing happened a few years ago. I did a System Restore to two different dates that were in the past two weeks, nothing.

Uninstalled MSE and disabled Windows Defender and the Windows Firewall: Nothing.

Reset IE Options, Reset Winsock, Dumping DNS, many of the other command prompt screens to reset items: Nothing.

Reset the modem: Nothing.

What DID work, however, was a ping test to Yahoo. The ping test worked, saying all four packets was recieved, yet nothing else popped up. LAN and CenturyLink said everything worked on their end and that everything was connected properly, as well as the speeds working fine.

CenturyLink said in their notes that they thought Port 80 was blocked. I went and put in the Firewall to allow Port 80 but it didn't make any difference whatsoever.

I remembered I had a spare modem laying around and I switched them up, both modem and the cords - nothing.

I then hooked it up to my netbook to see if that would work, as it usually does - connection didn't work there either.

Like I said, it's been about 24 hours now and this is increasingly frustrating, as I've tried all solutions (While browsing through 10 search results pages on my phone) suggested and still nothing.

Any suggestions and tricks would be greatly appreciated!

Here's my specs:

Windows 7 32-bit Home Premium
Intel Core 2 Duo 3.14 Ghz
4 GB Kingston DDR2 RAM
eVGA nForce 750i SLI
eVGA GeForce GTX 560 Ti FPB
ISP: CenturyLink
No router
Modem: CenturyLink 660 Series

PLEASE NOTE: This is the only computer I have (Like I said, the netbook solution didn't work), so downloading programs and such is not an option til I get to other computers somewhere else, like right now. Unless someone knows of a way of copying/pasting a file in Windows and then transferring said info to an Android smartphone, this is gunna take a while haha. Patience is requested.