My computer completely fails to even notice a certain USB device

[Closed]
Report
Posts
1
Registration date
Wednesday July 3, 2013
Status
Member
Last seen
July 3, 2013
-
I am using an HP Laptop with Windows 7 Pro.
I'm not bad with computers and can usually figure out most issues on my own, but this just baffles me. I have a USB game controller that USED to work on my HP Laptop, but now whenever I plug it in the computer completely fails to notice I've even plugged it in. This controller still works on every other computer I've tried it on. Any other USB device I've tried has worked in that port (and I've tried the controller in every port). I have uninstalled all device drivers under human interface devices and there are no windows controllers in the device manager. My computer does not make the noise it usually does when I plug the controller in and the controller does not show up as an unknown device in the device manager. In computer management I have checked the local storage to see if it just wasn't being assigned a drive, but that was not the case either. Has anyone else had this happen to them or does anyone have any insight on how to fix this?