Digital camera's SDHC unable to complete the format

[Closed]
Report
Posts
1
Registration date
Monday November 3, 2014
Status
Member
Last seen
November 3, 2014
-
Hi, I am new here and I need to format my digital camera's SDHC. I was taking a photo of my sister when the preview image didn't appear. So I tried viewing all the photos, but all photos are represented by a question mark, meaning they are in an unknown format. I turned it off then on again to see if it will be the same. But when I pressed the 'preview' button, a black screen with the message "Memory Card Error" on top and "Memory Card Locked" at the bottom appeared.

I then thought that it is corrupted. But since I don't have any backups of the photos, I tried to recover them using Recuva, Yodot, CardRecovery, ZAR, etc. But they all failed. So I thought of just formatting it and recover the files after. But when I tried to format it, a message "Windows was unable to complete the format" popped up. I tried formatting through "Disk Management" and cmd, but still I failed. I also tried third party apps like USB Disk Format and SD Formatter but to no avail, I still got nothing.

Can anyone help me please? It would really be a big help. Thank you. It's just that the SDHC is not even a year old. Thanks!!