Connected to Internet, but I can't surf the web + firewall issue

Closed
Report
Posts
1
Registration date
Friday July 24, 2015
Status
Member
Last seen
July 24, 2015
-
Hello everyone,

first of all I must apologise to you for my weak padronance of english. I hope that to read my question won't be a kind of grammatical torture.

Yesterday my pc desktop Dell - that I bought just one year ago - crushed without any apparent reason, showing a code of error that I didn't accomplished to keep in mind before its shotdown.
This morning I've noticed two bad issues.
1. even if I was connected to Internet (I use a rooter), I wasn't able to browse with any of my browser (firefox, chrome, IE).
2. I didn't manage to activate my McAfee's firewall (nor the Windows' Firewall) which was unexpectedly turned off. Anytime I've tried to turn it on, in about two minutes it returned off.

Regarding the first issue, I've already tried to use the "cmd solution" posted in other similar posts, but it didn't work for me.
I think the two issues I reported are strictly related, and I think the source of both is a kind of virus infection I cannot detect. I run a scan with mcafee security scan plus, and then with adwcleaner. Nothing has been found.

Do you have any hint to help me solve these problems?
Thanks for the time dedicated to me.