GalaxyS. I need to upgrade the O.S.

Closed
69Rixter Posts 60 Registration date Wednesday March 25, 2015 Status Member Last seen November 25, 2022 - Sep 22, 2015 at 06:02 PM
I have a first gen GalaxyS. I need to upgrade the O.S. Could someone tell me what the latest distro this phone will support/can handle?

THANX:
RICK