Some keys on Toshiba laptop (Satellite C855-1UN) does not work

[Closed]
Report
Posts
1
Registration date
Tuesday October 20, 2015
Status
Member
Last seen
October 20, 2015
-
Hello,

few days ago I reinstalled Windows 8 on my laptop, and next day I took it to the local comp service and got it cleaned. The same day I noticed that space bar and [1;!] , [2;@] keys were not working. I restarted computer and they worked, next day they did not, again.. So sometimes they work, and sometimes they do not. (this changes occur only after restarting or shutting down and unplugging computer, not during the working process).

So I took it back to the same service, they took a good look of it, cleaned the keyboard properly and it worked. I brought it home and it was not working again. I took it back to them again and they told me if there was some mechanical damage caused after cleaning computer, then the keys should have stopped working altogether.

My battery was dead for almost a year, but I still kept it in and worked with a cable. Repairer told me that maybe the battery acid leaked and caused some damages to the windows. He suggested reinstalling it again and buying a new battery.

Before I do so, I wonder is this really possible? There are no leaks on the battery. Maybe someone could suggest any other causes of malfunction? Please help! :)