Google Chrome turn off translation [Closed]

Report
Posts
1
Registration date
Thursday January 21, 2016
Status
Member
Last seen
January 21, 2016
-
No matter what I do I cannot get rid of the translation option. It even translates my name in messages. I have unchecked the translate box in "settings" and nothing changes.