Fn is not working [Closed]

Report
-
Hello, I recently (About 3 months ago) bought a laptop (GIGABYTE [Windows 10]). I was using it just fine until a few hours ago... Then suddenly the Fn keys started to not work. I looked through a lot of different forums.

I tried:

1. Pressing Fn + Numlock Key
2. Pressing Fn + Shift + Number Keys
3. Pressing Fn + ESC
4. Pressing Fn + Alt + Windows Key

5. Restarting my Laptop
6. Going into the Windows Mobility Center to see if there's "Function Key Behavior" (There wasn't)
7. Restarting my Laptop and Pressing F2 to go to the setup screen where I had to navigate using arrow keys, and found nothing related to "Function Keys" even in the advanced tab.
8. Going into the Control Panel to look for "Keyboard" related things -> Nothing related to "Function Keys" were found.

The only thing I've been doing these past few days were working on the a computer game mod... And I haven't downloaded anything except a number of videos from youtube(Using the Mozilla Firefox addons).

At this point I think I've tried everything I found... And nothing seemed to have worked. Does anyone know how to solve this problem?

- UPDATE -
While I was waiting for the answers to come, I basically did a factory reset of my laptop, since one of my friends suggested it. However.... EVEN AFTER THE RESET the Fn key doesn't work... As if it didn't exist in the first place, I can't locate anything related to it in the control panel, mobility center, and in the BIOS setup screen.