Logitech X-540 Speakers No Sound (Partially)

[Closed]
Report
-
 eses -
Okay so since my old speakers are broken I brought these new ones.

I installed it as in manual says, everything worked when I tested it with youtube on internet explorer then I went to play an mmorpg and then realized theres no sound from the game. So that was odd but then afterwards when I tried to test it with a few other programs, msn had sound, wmp had sound too, but firefox didn't.

Maybe I'm drawing conclusions too early but...so fair its microsoft/window related program works with sound but the other doesn't? Anyone have any ideas why?

tyty

3 replies

I had this problem too. RealTek apparently sets the playback volume WAY lower than it should be for these for some reason (idk, RealTek sucks and its developers ought to be executed imo). I shut my computer off, plugged in the speakers, started it up again and checked RealTek, which is when I found out it had been stifling my speakers tremendously. Let me know if it works.
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

ads
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month


Okay, real player worked too...but still...