Hardware Forum

Ask a question
Search
Close
Results 1 - 50 of about 48,800
  • Toshiba Satellite randomly turns off after 20-30 mins

    Im not sure if my problem leads to overheating but i never had this kind of issue before once i play a game just start up run it for 20-30 mins (roblo...

    dreagtr | Laptop | Latest reply: HelpiOS Feb 07
    1 reply
  • Stuck at dell logo also not entering on bios

    Hello, My laptop stuck at dell logo and  also not entering on bios mode .  Its all happen when i partition the ssd and then restart my computer .. ...

    Surajchaudha... | Laptop | Latest reply: HelpiOS Feb 06
    1 reply
  • ITX motherboard lights on but no cpu spin

    Hello, First time poster here. I have an Asrock X570 ITX phantom gaming board that I don't know for sure if it works. I've tried to test the board us...

    mashpotato | Motherboard | Latest reply: HelpiOS Feb 02
    3 replies
  • lenovo T470 power LED blink 3 time but it's not powering up Solved

    I have managed to solve this issue after following the below steps. 1. remove batteries(both internal and external 2. remove RAM and CMOS battery ...

    hemantha | Hardware | Latest reply: Eliseiuwka Feb 02
    2 replies
  • Scanning issues Samsung Closed

    Dear all, I have an scanning issue with the printer/scanner Xpress M2070W. After the reinstall of OS, the reconnection of the printer did not work as ...

  • Unable to get WiFi with D-link router in Dell Inspiron N5040 Solved

    Hello, In my Dell Inspiron N5040, I am unable to get wifi. I can easily get broadband but not wifi. I use a D-Link router.  I tried many hacks menti...

    babu7 | Laptop | Latest reply: babu7 Jan 30
    2 replies
  • Unable to download videos to my aiworth mp3

    Hello, i am Unable to download videos to my aiworth mp3

    Helpmeplease | Hardware | Latest reply: Helpmeplease Jan 30
    0 replies
  • Dell Inspiron R15 5520- One RAM slot is not working -beeping

    My Dell Inspiron 15R 5520's upper RAM slot is working fine. But when I put the same RAM stick in the lower RAM slot, it causes beeps, and the laptop d...

    AlphaBravo1 | Hardware | Latest reply: AlphaBravo1 Jan 27
    0 replies
  • Plz,fix me my problem I have Dell laptop

    Hello, My laptop fan is continuously running for an hour and after that time at it not stopping ,As I was watching YouTube video then I fold the la...

    Fatim | Hardware | Latest reply: vishvajit Jan 24
    1 reply
  • 3 Beeps noboot. New Ram, please help

    Hi. my pc makes 3 beeps and the wont boot up or show any display. I removed the rams and replaced them with new ones.  I cleaned the ram slots. I trie...

    Ezzo | Motherboard | Latest reply: HelpiOS Jan 22
    1 reply
  • How do I insert the the hash # character on the keyboard Solved/Closed

    Can someone please help me with inserting the hash # character from the Keyboard of my New Lenovo G505 Laptop

    Jaytouch | Keyboard | Latest reply: Smile Jan 22
    12 replies
  • Hash # key on keyboard in Lenovo yoga 530 Solved/Closed

    Hello, Please can any one guide me how can I type Hash # on keyboard of LENOVO YOGA 530?

    hussainnrm | Keyboard | Latest reply: Olurachey Jan 22
    2 replies
  • Fan runs so fast but cpu is not rebooting Solved/Closed

    Hello, I would like to have some help bec our cpu is not rebooting but the fan runs so fast. Was the motherboard problem?

    Ai | CPU/Desktop | Latest reply: Johnny Jan 20
    2 replies
  • Is to ok to have a intel arc laptop for after effects?

    I have to work on After Effects, and I need a laptop with powerful processor and a dedicated graphics card. The graphic card i want to go with is inte...

    aaron.jeffery | Hardware | Latest reply: aaron.jeffery Jan 19
    0 replies
  • Pc is on but no display

    Hello, mine pc is on but no display on screen the fans are spinning fast but hdd activity light is not even blinking though. I have tested changing ra...

    Amanpreet | Hardware | Latest reply: HelpiOS Jan 19
    2 replies
  • Inspiron 13 7000 won’t turn on

    title Inspiron 13 7000 won’t power up  I have a dell inspiron 13 7000 that won’t power on  I tried the battery disconnect and pushing power b...

    Bob | Laptop | Latest reply: HelpiOS Jan 19
    4 replies
  • select a proper boot device or insert boot media

    Hello, sooo i downloaded ubuntu aside to windows 10 on my Toshiba satellite laptop and it was working until i shut down my laptop and then it wouldn...

    tbo | Laptop | Latest reply: HelpiOS Jan 17
    3 replies
  • have or nothing Solved

    hi hello please ask me if Acer Aspire ES 15 model ES1-572-33ZU have a backlight keyboard?

    batang-akrho... | Keyboard | Latest reply: HelpiOS Jan 11
    1 reply
  • Cannot type @ on my acer laptop. Solved

    Hello, Cannot type @ on my acer laptop. Please help fix it. Configuration: Mac OS X / Safari 10.3.2.2639

    cornelius | Laptop | Latest reply: Oma Jan 10
    6 replies
  • Not your average hard drive problem...

    Hello, I have a Seagate Barracuda 2TB HDD that is technically working fine, but it is running some kind of internal process that takes up 100% of its...

    MutleyEugenius | Hard Drive/SSD | Latest reply: EZ_Nerd Jan 09
    1 reply
  • Request information about SAMSUNG Q-Series HW-Q990B/FZ

    Hello, at the beginning of December, I bought a SAMSUNG Q-Series HW-Q990B/FZ soundbar, which was 25% off at a fnac merchant Yeppon.it The first obs...

    roky333 | Hardware | Latest reply: EZ_Nerd Jan 06
    1 reply
  • Toshiba laptop shuts down instantly on start Solved

    Hello, my toshiba laptop screen suddenly went blank,now everytime I try an turn it on it instantly shuts down within a second,i cant get into any ki...

    madforit | Laptop | Latest reply: Kathleen Jan 06
    21 replies
  • Can I find my stolen WB Passport external hard drive? Solved/Closed

    Hello, I am looking for my stolen WB Passport external hard drive

  • My hp elitebook revolve 810 laptop won't turn on

    Hello, I've been trying to turn on my hp elitebook revolve 810 laptop but it doesn't wanna turn on. When I plug in the power supply it's a dimmer ligh...

    mya | Laptop | Latest reply: saramarzo Dec 30, 2022
    1 reply
  • How to access BIOS or Remove HDD password? Solved/Closed

    Hello, I set an HDD password for my "Toshiba Satellite L850-A848" laptop. Now I can't get to the BIOS settings. So, how can I open the BIOS? if ...

    n1amr | BIOS | Latest reply: ahmed Dec 30, 2022
    8 replies
  • Connex Slim Book won't turn on Closed

    Hello, my connex Slim Book won`t turn on. When connected to the charge, charging light is working properly but the on light only blinks briefly and ...

    tChakabva | Laptop | Latest reply: Parks Dec 23, 2022
    2 replies
  • Kingstone data Traveler 32gb is write protected Solved

    Hello, Dear Supporter I have one flash drive model kingstone data traveler 32gb but I can not format it when I format it show mesag medai is write...

    freedom | Hardware | Latest reply: Ghost Dec 16, 2022
    19 replies
  • How do I type the @ on a British keyboard? Solved

    Hello, I have bought my brother a computer here in the USA and now I have set it up for the UK.....Doing all the nice things on the computer for hi...

    Steve | Keyboard | Latest reply: jonearthur Dec 15, 2022
    7 replies
  • My Toshiba keeps turning on and off

    Hello, So, I have a Toshiba satellite L875-S7208, and I tried to do a reset. Both resets failed and on the second one the laptop keepings turning on ...

    SariaMcCloud | Laptop | Latest reply: Irina2207 Dec 7, 2022
    1 reply
  • Left shift key has been typing out this symbol "|" Solved/Closed

    Just recently, my left shift key has been typing out this symbol | when I press it. But only when I press it on the left side closer to the Z. This is...

    Dislexiya | Keyboard | Latest reply: Philly Dec 3, 2022
    6 replies
  • LG monitor it keeps saying D- Sub, power saving mode Closed

    Hello, I'm in need of help of my LG monitor it keeps saying D- Sub, power saving mode? how do I get out of power saving mode? System Configura...

    Joshua Conley | Monitor | Latest reply: Raif Dec 3, 2022
    5 replies
  • USB bluetooth adaptor

    I have a USB bluetooth adaptor/dongle which was running fine then one time it stops working. The laptop does not recogize it, nor does the pc and when...

    sidkeyco | Hardware | Latest reply: sidkeyco Dec 2, 2022
    0 replies
  • Lenovo ideapad motherboard's capacitor Solved/Closed

    Hello, I own a lenovo ideapad gaming 3 15.6" laptop So, yesterday I was upgrading my RAM into 16GB, everything was going fine until, trying to put...

    maejortrippy | Laptop | Latest reply: Zalatunji Dec 1, 2022
    22 replies
  • Dactyl-ManuForm vs Kinesis Advantage 360

    I am in the market for a split orthonormal ergonomic keyboard. I have an issue with my shoulder that gets worse when I type. I bought an Ergodox EZ a...

    currenthandle | Keyboard | Latest reply: currenthandle Nov 30, 2022
    0 replies
  • Confusion Between Gaming Laptop & Desktop

    Greetings, Community! I want to get a new gaming device for myself, but I'm not sure if I should get a gaming laptop or a gaming desktop. Please let...

    millismith | Laptop | Latest reply: millismith Nov 29, 2022
    0 replies
  • Keyboard arrow keys not functioning

    Hello, I'm Having some issues with my keyboard. It is a redgear mechanical keyboard MK853 (2017 or later model) and whenever I press the left arrow k...

    Rishon | Keyboard | Latest reply: Rishon Nov 26, 2022
    0 replies
  • My laptop is not working. I tried power on and off.

    Hello, also no luck for ctrl+alt+del ..also tried power on off no luck​​​​​​​

    Rani | Laptop | Latest reply: Rani Nov 25, 2022
    0 replies
  • Screen is black

    Hello, My laptop screen went black while I was going through slides and won't light back up, the power light is on

    Noni | Laptop | Latest reply: JaceBranyan Nov 24, 2022
    5 replies
  • Laptop wont turn on

    Hi. Laptop stopped turning on. When i press power buttom it powers on fan starts spinning for 2 seconds then shuts off . Keyboard light comes on and i...

    Jello | Laptop | Latest reply: JaceBranyan Nov 24, 2022
    1 reply
  • How to force blue screen of death

    i have a dell chrome book and i have Chrome OS i think? i wanna distory this chrome book with virus but they did not work so i went to plan B AKA i tr...

    JaceBranyan | Laptop | Latest reply: JaceBranyan Nov 24, 2022
    2 replies
  • Touchpad got suck after some time

    Hello everyone. I am using window 10 on Lenovo laptop. It is Thinkpad series. Now the issue is that its touch pad got stuck after some time. I have do...

    Clark213 | Laptop | Latest reply: HelpiOS Nov 23, 2022
    1 reply
  • Display problem

    Hello, I have this display problem, it sometimes occurs while surfing web. I'm using windows 10 on a 144hz display laptop. Anyone have an idea about t...

    Leophan | Laptop | Latest reply: Leophan Nov 22, 2022
    0 replies
  • Laptop Shut down by itself Solved/Closed

    Hi I was doing some stuff on my laptop and it just shuts down and lost my work. And I notice that everyday it does this with me.do you think it's a vi...

    bobgure | Laptop | Latest reply: 111Leah Nov 21, 2022
    33 replies
  • glitching keyboard

    i spilled alcohol on my keyboard which bugged my keyboard. every time i press a button like h, my brightness goes down and my keyboard lighting change...

    forsaken | Keyboard | Latest reply: forsaken Nov 19, 2022
    0 replies
  • 1 White light blink after a 5-second gap on Dell Inspiron

    I installed a new CPU cooling fan in my Dell Inspiron N5040 as the old one was damaged. Now, whenever I try to power it on through AC power, the whit...

    babu7 | Laptop | Latest reply: HelpiOS Nov 16, 2022
    2 replies
  • e6400 stuck in a bootloop

    I can't get out of my latitudes bootloop. I set the bios for data etc, then it says inaccessible boot device, I change the settings to the other instr...

    bodhi | BIOS | Latest reply: bodhi Nov 13, 2022
    0 replies
  • What's the most key point when you decide to get a 3d printe

    As the title said, what's the key point when you want to get your first 3d printer? Speed or others?

  • My Toshiba satellite touchpad not responding

    Hello,My Toshiba satellite touchpad not responding the cursor has not responding the command please help me 

    Abayshimelis | Laptop | Latest reply: HelpiOS Nov 10, 2022
    1 reply
  • 32gb Samsung Showing Only 14gb Closed

    Hello, I have a 32GB samsung 3.0 USB drive but its only showing 14.6 GB total space

  • Keyboard Backlight Solved

    Hello, I just got an acer aspire e 15 es1-511-c9xb. I don't know of it has Backlit keyboard. Please if it does, how do I enable it?

    Vicoco | Laptop | Latest reply: HelpiOS Nov 1, 2022
    1 reply