WhatsApp Bluetooth calls issue

Sleek - May 14, 2023 at 05:14 AM
 hransheed - Aug 23, 2023 at 06:38 PM

Hello,

When someone calls me on whatsapp (voice/video) on my Samsung 23+ and i connect my buds2 pro (after or before i answer) i can hear the connection chime but i cant switch to bluetooth in the call, if i press the bluetooth button it lights up for a second and turns off after and the sound still comes from the loud speaker.

Every time i want to use my buds i have to end the call, exit the whatsapp app reconnect the buds if they are not connected already and go into the app again and call the person back.

Any fix for this issue ?


Android / SamsungBrowser 20.0

Related:

4 responses

Thank you for trying to help. Appreciate it. I'll contact WhatsApp bcoz I also found other people with a similar issue. 

1
HelpiOS Posts 14296 Registration date Friday October 30, 2015 Status Moderator Last seen April 15, 2024 1,891
Updated on May 17, 2023 at 04:56 AM

Ok, it is maybe a problem with the app itself then...
Hope it will be fixed soon.

0

Its the problem with all the Samsung phones in WhatsApp application.

Neither WhatsApp nor Samsung is addressing this issue.

1
HelpiOS Posts 14296 Registration date Friday October 30, 2015 Status Moderator Last seen April 15, 2024 1,891
May 14, 2023 at 10:47 AM

Hi,

Open Settings and go to Connections > More connections settings to make sure Nearby device scanning is turned on. Next, go to Apps > WhatsApp > Permissions and set Nearby devices to Allow.

If the issue persists, check that WhatsApp is on the latest version and try whitelisting it from battery optimization.

Hope this helps.


0

Hi. First of all, thank you for your suggestions. My "nearby devices" was already on. I removed WhatsApp from battery optimization but the problem still persists. It's frustrating a bit but thank you again for trying to help. 

0
HelpiOS Posts 14296 Registration date Friday October 30, 2015 Status Moderator Last seen April 15, 2024 1,891
May 15, 2023 at 09:37 AM

Hi,

Check that your earbuds are allowed to make phone calls. Go to Settings > Connections > Bluetooth (turn it on). Under "Available devices" or "Paired devices", select the settings icon next to your earbuds, then enable Calls in the Use for section.

If this doesn't work, back up your WhatsApp chats by selecting the 3 vertical dots > Settings > Chats > Chats backup > Back up, then uninstall WhatsApp.

Restart your phone and reinstall WhatsApp. Once WhatsApp is reinstalled, give all the necessary permissions for the app.

If the problem persists, try resetting your Samsung earbuds.


0

Hi. Thanks for the suggestions. "Enable calls and audio"  were already enabled. I uninstalled and reinstalled WhatsApp to no avail. Also reset my buds but that didn't help. I even tried the calls with my Sony noise cancelling ???? but it didn't help. 

1
HelpiOS Posts 14296 Registration date Friday October 30, 2015 Status Moderator Last seen April 15, 2024 1,891 > Sleek
May 16, 2023 at 09:12 AM

Sorry to hear that. Unfortunately, I'm out of ideas... Just make sure your phone and earbuds are on the latest version. Here's how to update your Samsung earbuds.

If that doesn't help either, then I suggest you report the problem to WhatsApp by opening the app and going to Settings > Help > Contact Us.

Good luck 

0