God Help

The_Guru - Jan 12, 2009 at 11:34 PM
 The_Guru - Jan 14, 2009 at 08:04 AM

Problem Summary: I can\'t access my USB drive i just bought.
I just bought a new USB drive, Kingmax super stick 8GB. The first time i inserted into my laptop(windows XP), there was a pop up window and say something like "the device is ready to use". Then i open My Computer and found a new removable drive(F:) but when i double clicked the drive it said "Please insert a disk into a Removable Disk (F:).", so i tried to format the drive and it said "There is no disk in drive F:. Insert a disk, and then try again."

please help me please

1 response

whineup Posts 39 Registration date Monday December 29, 2008 Status Member Last seen June 18, 2009 26
Jan 13, 2009 at 04:23 AM
The last time you removed you Pen Drive, did you use the Safely Remove Hardware Option, if not just close (properly) all USB devices connected to your PC, restart your PC and try again
i am tried everything but i am not done that pendrive and data inside it is really very precious to me what to do i am hopeless