RE: pendrive showing write protected

Closed
xdkenzo Posts 1 Registration date Saturday May 4, 2013 Status Member Last seen May 4, 2013 - May 4, 2013 at 07:19 AM
xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 - May 4, 2013 at 12:11 PM
Hello,

i have the same problem but when i do the following steps i.e HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\storatedevicepolicies i cannot find "storatedevicepolicies"
i come up to HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\ and that all.. where is the "storatedevicepolicies" ??

Thanks

1 reply

xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,829
May 4, 2013 at 12:11 PM
I suggest you try these instructions:

1) Click Start->Run.

2)Type regedit and hit enter.

4)Click on the plus sign next to HKEY_LOCAL_MACHINE

5)Click on the plus sign next to SYSTEM

6)Click on the plus sign next to CurrentControlSet

7)Click on the plus sign next to Control

8)Click on the plus sign next to StorageDevicePolicies

9)Write click on WriteProtect and click modify.

10)If the value data is 1 change it 0 and click ok.

11)Repeat steps 7 to 10 for ControlSet001 and ControlSet002 .

12)Close Registry editor and restart the computer.

-------------------------------------------------------------
If you don't find it in the registry, the best way is to create it yourself. Below is the procedure.

Start the Registry Editor

Go to the HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control key

If there is no key called StorageDevicePolicies, create it
.
You do this by right-clicking the HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control key, and selecting New > Key from the menu.

Select the StorageDevicePolicies key

From the menu select Edit > New > DWORD Value

Name the new value WriteProtect

Right-click the WriteProtect value and choose Modify

In the Value Data: box enter 1

Exit the registry editor, and restart your computer
0