No display after new motherboard installed

Posts
3
Registration date
Thursday September 27, 2018
Last seen
September 27, 2018
- Sep 27, 2018 at 12:24 PM - Latest reply:
Posts
10849
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
November 15, 2018
- Sep 28, 2018 at 04:45 PM
Hello,


I recently bought a new motherboard MSI Z7S krait and when I installed it my computer does not seem to be working.
-no display
-power button glows and cpu fan spins
-odd behavior where about 30 sec in it seems to "restart?" white power button goes off for a sec or 2 and cpu fan stops before restarting

I know the Z7S is compatible because that was my original motherboard (replaced it with AS rock H81 pro btc R2.0 temporarily after prev one burned out) Computer was function with the Asrock motherboard but it lacks USB 3.0 support for case so wanted my Z7S krait back.

other specs
PSU= Antec 620
CPU= I5-4590
ram: Gskill DDR3-1866 PC3-14900 8192 mb x2 ( I tried testing with only 1 ram stick, no change)
hard drive: 1x 128 GB SSD and 1x 1TB 7200 rpm
graphics card: GTX970 -also tested without graphics card using mobo VGA connector
speakers: logitech (does not say model on speakers)

other info: no speakers integrated into mobo or case, so not sure if would even hear any error beeps if they existed

I can take pics if needed, cannot tell if I plugged something in wrong, or if mobo busted or what else is going on. Please help

See more 

Your reply

6 replies

Posts
10849
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
November 15, 2018
- Updated by ac3mark on 27/09/18 at 05:22 PM
0
Thank you
If you want to hear the beeps, there should have been a piezo speaker that came with the MB. plug it into the ports located on the diagram!

Posts
10849
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
November 15, 2018
- Sep 27, 2018 at 05:24 PM
According to specifications, and the ones you posted, your ram does not match. The MB is DDR2, and the ram you specified is DDr3.

This is from https://www.cnet.com/products/asus-z7s-ws/specs/

SUPPORTED RAM
Bus Clock 800 MHz, 667 MHz, 533 MHz
Registered or Buffered Registered, fully buffered
Features Four DDR channels
Speed PC2-6400, PC2-5300, PC2-4300
Technology DDR2
Max Size 24 GB
Supported RAM Integrity Check ECC
Posts
3
Registration date
Thursday September 27, 2018
Last seen
September 27, 2018
- Sep 27, 2018 at 05:57 PM
sorry, not asus, MSI, seems I forgot the 9 in post
"Original MSI Z97S SLI Krait Edition Motherboard"

"If you want to hear the beeps, there should have been a piezo speaker that came with the MB. plug it into the ports located on the diagram! "
I bought it on ebay, did not recieve any speaker with it, just the metal faceplate for case, and 2 sata cables
Posts
10849
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
November 15, 2018
- Sep 27, 2018 at 07:09 PM
Ok, sorry to hear about the slack delivery.

So, does the ebay seller take returns?
Posts
3
Registration date
Thursday September 27, 2018
Last seen
September 27, 2018
- Sep 27, 2018 at 07:22 PM
well, that is part of what I am trying to solve, is the motherboard truly fried?
if it did noit respons at all or if the CPU fan did not spin I would have my answer
but fan spins, light comes on, and I do not know how to test further
Posts
10849
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
November 15, 2018
- Sep 28, 2018 at 04:45 PM
Unless you have a test rig, you have no way of determining if the seller sold you junk! You already said it didn't include a speaker, which new ones have! Do you have a diagram with test points to test voltages?
Respond to ac3mark