C and D:\ drive asks me open with [Solved/Closed]

naughtyrohit - Aug 10, 2009 at 02:47 AM - Latest reply:  Rvi aiden
- Jul 26, 2015 at 06:36 AM
When I double click on the D:\ drive on my notebook it doesn't open automatically, rather it starts the OPEN WITH menu and asks
Choose the program you want to use to open this file: D:\ and gives a list of programs. This error was not there earlier, but has been coming for some time after I detected and removed a virus otorun.inf from my d: harddisk using pc-cillin by trendmicro. I have to access the D: hard disk using windows exploer. Pls help and tell me how I can go back to double clicking to access D:\.

DUDE I TRIED THIS ONE BUT IAM HAVING THIS SAME PROBLEM. EVERY TIME I SHUTDWN MY PC THIS PROBLEM OCCURS. I THERE ANY PERMANENT SOLUTION FOR THIS.....
See more 

8 replies

Best answer
xpcman 19105 Posts Wednesday October 8, 2008Registration dateModeratorStatus July 18, 2018 Last seen - Aug 10, 2009 at 10:58 AM
6
Thank you
Virus trouble

Sometimes it happens in windows XP that you are not able to open drives on your hard disk. When you double click on the drives icons or right click on the drive>>explore in My computer ,the drive does not open.

This problem is generally caused by most of the viruses which infect windows XP system. They block or restrict your access to any of the drives.

But don’t worry this is not a big trouble it can be fixed easily.

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\ this takes you to the root directory

3. type attrib -r -h -s autorun.inf this changes the file attributes to allow its deletion
4. type del autorun.inf

5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your trouble will be fixed.

Thank you, xpcman 6

Something to say? Add comment

CCM has helped 1692 users this month

i also have the same problem if I type attrib -h-r-s autorun.inf
it shows msg invalid--h-r-s switch
what can I do plz help me
Your email address has been removed for your own seecurity.
xpcman 19105 Posts Wednesday October 8, 2008Registration dateModeratorStatus July 18, 2018 Last seen > veerendra - Nov 5, 2009 at 11:11 PM
you probably have the spacing wrong.

attrib -r -h -s autorun.inf

attrib <space> -r <space> -h <space> -s <space> autorun.inf

no space between the - and the letter


Good Luck
if not open your drive
go to run type regedit
select my computer
Press Ctrl+f
type mountpoints2
if found delete it
then press f3 repeat it again an again
reboot
then open your drive
Krishna Reddy > js - Dec 1, 2009 at 10:19 AM
Really thanks alot .My problem has rectified by u r solution........................
Thanks a lot dude my problem is resolved now....
naughtyrohit - Aug 11, 2009 at 06:05 AM
2
Thank you
Tx for replying and my problem is solved now I can open my drive in double click. But the "mountpoints2" virus file is always displayed in registry. Hope it wont create any proble. Once again tx man. ^__^
0
Thank you
Thanks a lot for your solution... reallly worked for my comp!!!