2nd SATA HD not seen in 'My Computer'

Closed
crashedagin
Posts
1
Registration date
Thursday August 20, 2009
Status
Member
Last seen
August 21, 2009
- Aug 21, 2009 at 01:04 AM
 nada - Dec 2, 2009 at 01:05 AM
Hello,

Slightly different twist to otherwise similar headache with 2nd SATA drive. MY PC has only one hard drive - WD320 SATA with XP PRO on it. Connected a 2nd WD320 SATA (brand new) to the remaining SATA port on MB, disk spun up fine. Unable to see the drive in 'My Computer', but it does show up in Device Manager - correctly identified and shown as 'working properly' with all correct drivers etc. It does NOT show up in Disk Manager however, so any answers about partitioning and formatting the drive first seem impossible at this point. Tried it on another PC and same problem - seen on Device Manager but nowhere else.
I have read all the posts but can find nothing that works so far. Any ideas from left field out there?

Thx

4 replies

CyborgCop
Posts
48
Registration date
Tuesday August 25, 2009
Status
Member
Last seen
September 10, 2009
12
Aug 25, 2009 at 11:04 PM
if it's brand new.. you'll have to active it first. . Right click on my computer.. click on manage.. Then go to Disk Management.. you should see your hard drive there... Right click it and click on activate.. Then from there you can format and partition it..
1
i have the same problem but when i go to the disk managment the drive is not there ... even tho in bios it is
1
right click on (my) computer or computer in the start window
go to manage
click on disk management
mine ended up as a foreign disk and as disk 0
I right clicked and import foreign disk and it was recognized.
1
CyborgCop
Posts
48
Registration date
Tuesday August 25, 2009
Status
Member
Last seen
September 10, 2009
12
Sep 10, 2009 at 07:44 PM
You probably don't have the SATA drivers loaded for windows then. They should be on your motherboard disk. Or if you lost it you can go to the manufacturer's website and find your model and download them.
0