Can't copy big files to micrso SDHC 8GB [Solved/Closed]

niv - Nov 28, 2009 at 05:27 AM - Latest reply:  cocopuffs
- Oct 29, 2012 at 11:35 AM
Hello,
I have an 8GB micro SDHC card class 6 of SanDisk with a card reader (such as: http://www.amazon.com/...

I formated it and in the properties it does say it's 7.6GB (~8GB). However, when I try to copy into it a 4.5GB file, it says: "The disk in the destination drive is full. Insert a new disk to continue".
I reformatted and restarted the PC, and tried different files but got the same result.

Under FORMAT option I only have FAT32.

Can someone help?

Thanks,
See more 

9 replies

Best answer
33
Thank you
Doing a bit of research, I learned that a disk can be optimized "for performance" or "for quick removal". By default USB drives are optimized "for quick removal" which limits them to FAT filesystems. In order to have the choice for NTFS format:

- right click the USB drive
- go to the "Hardware" tab
- find the disk in the list and double click it
- go to the "Policies" tab
- select "Optimize for performance"

Now you should be able to format as NTFS and copy files larger than 4gb!

Thank you, sk1llz 33

Something to say? Add comment

CCM has helped 1796 users this month

Thanks a ton for this tip. I saw the different optimization methods when I was trying to figure out the problem, but I don't think I would have guessed that switching it would allow you to format to NTFS.
Thanx for ur help.
Thanks a lot. My head was driving me crazy.
thankyou very much, really
awesome tip.. thanks bigguy:D
1
Thank you
It did not work for me. So I reformatted the card to FAT32 and split the file with the file splitter provided with Glary Utilities program (free). Use the User Define Option about 100MB each and add Self-joining functionality. When doing so you also get a .exe file that will allow you to rejoin the file. Copy these files one at a time onto your card. Now all you have to do is to rejoin the files on the card.
Et voilà!
iveal 2802 Posts Thursday May 14, 2009Registration date September 28, 2010 Last seen - Nov 29, 2009 at 06:37 AM
-1
Thank you
Dear Sir,

Consider making back up copy of the files on the SanDisk and

carry up a format and hence have the problem fixed. This can

actually be resulting from a corrupted file on the SanDisk.

Thanks in advance.
Thanks for replying. Actually I solved the problem by defining the format to be NTFS instead of FAT32. I just needed to look in the web on how to make it since I didn't have the option to format to NTFS in the options.
Thanks.