Gta sa multiplayer

[Closed]
Report
-
 Blocked Profile -
Hello,
i have gta sa v1.1,and i download it mta sa(multiplayer) from gamespot,when i try to run it it says version 1.1 is not supported or invalid serial nuber,please reinstall mta.plz help meeeeeeeee.

1 reply


hi there,

for testing game compatibility with your system

link below from faq section will help you:

https://ccm.net/faq/1709-how-to-check-the-compatibility-of-a-game-online

Thanks