Asus T9400 series wont start

Closed
PK711 - Apr 17, 2010 at 07:01 PM
 chia - Aug 31, 2010 at 04:10 AM
Hi,

I have an old ASUS T9400 series, which was running sluggish and keep turning off by itself every now and then. I opened it up and removed the processor and re-sat the processor, hooked up everything and tried to turn it on but it wont even go as far as the ASUS screen. the lights turn on for battery and power and occasionaly a blip for the hard disk, but laptop doesnt turn on. Even the fan doesnt run

Then I tried to remove the processor and it the on button again, this time the fan is running with the aforementioned lights, obviously computer doesnt boot to ASUS screen.

If I put the processor back in and try to turn it on, the fan doesnt run and its back to square one. any ideas anyone? I am thinking I may have damaged the processor or the mother board. Which is which.

1 reply

Mine too. I've contacted Asus. Most probably the on-board RAM is faulty. And they claim there is no jumper to bypass it. Therefore, the only solution is to get a new MOBO... else just get a new notebook (due to costing practicality) ...... like me :-)

In the meantime, i've dismantled the whole thing, and selling it as parts :-D

check out www.mudah.my and search Asus ... u will find my parts there :-D

cheers....
Chia
0